summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSampson Crowley2022-04-02 13:43:30 -0600
committerSampson Crowley2022-04-02 13:43:30 -0600
commitbe55075b612a6bbeac8828091e8eeac1f149f36f (patch)
tree48ba761780919c179221ec8f9010ff279e95a921
parent7236648212b2884dd38678e2b7206911df056392 (diff)
downloadaur-be55075b612a6bbeac8828091e8eeac1f149f36f.tar.gz
upgpkg: heroku-cli 7.60.1-1
upstream release heroku-cli 7.60.1-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afb7affab237..02f852424d5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = heroku-cli
pkgdesc = CLI to manage Heroku apps and services with forced auto-update removed
- pkgver = 7.59.2
+ pkgver = 7.60.1
pkgrel = 1
url = https://devcenter.heroku.com/articles/heroku-cli
arch = any
license = custom
license = ISC
- makedepends = npm
makedepends = yarn
makedepends = perl
makedepends = git
@@ -19,7 +18,7 @@ pkgbase = heroku-cli
conflicts = heroku-toolbelt
conflicts = ruby-heroku
options = !strip
- source = git+https://github.com/heroku/cli.git#commit=77bd72011382a9896b8829a1fb206b931dd0babf
+ source = git+https://github.com/heroku/cli.git#commit=4e998800e9bde9b30d97e465f1e2c066c5734ff5
sha256sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b2a8ad332de7..46c599098957 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
# Github Contributor: Joey Dumont <https://github.com/joeydumont>
pkgname=heroku-cli
-pkgver=7.59.2
+pkgver=7.60.1
pkgrel=1
-_commit_id="77bd72011382a9896b8829a1fb206b931dd0babf"
+_commit_id="4e998800e9bde9b30d97e465f1e2c066c5734ff5"
pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
arch=('any')
url="https://devcenter.heroku.com/articles/heroku-cli"
license=('custom' 'ISC')
depends=('nodejs')
-makedepends=('npm' 'yarn' 'perl' 'git')
+makedepends=('yarn' 'perl' 'git')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-cli-bin' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
source=("git+https://github.com/heroku/cli.git#commit=${_commit_id}")
@@ -54,8 +54,8 @@ prepare() {
# remove forced auto-update plugin
sed -i "/oclif\/plugin-update/d" ./package.json
- # install dependencies, must be done with npm
- npm install
+ # install dependencies, must be done with yarn as of 7.60
+ yarn install
# remove dist folder if necessary
if [[ -d "./dist" ]]; then