summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSampson Crowley2021-03-22 21:44:30 -0600
committerSampson Crowley2021-03-22 21:44:30 -0600
commitdc6d6005a24554066d0d8ed67f4f3e9b0946a88d (patch)
tree1bc2f26761211846ef6509645e8616f23f512998
parentca2b4591dd291476de6b2bc4dc4c8928b8b84dbf (diff)
downloadaur-dc6d6005a24554066d0d8ed67f4f3e9b0946a88d.tar.gz
upgpkg: heroku-cli 7.51.0-2
remove npm makedependency from heroku-cli
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b353ce5aa58..7a5c70a0a8ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = heroku-cli
pkgdesc = CLI to manage Heroku apps and services with forced auto-update removed
pkgver = 7.51.0
- pkgrel = 1
+ pkgrel = 2
url = https://devcenter.heroku.com/articles/heroku-cli
arch = any
license = custom
license = ISC
- makedepends = npm
makedepends = yarn
makedepends = perl
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index a4f08a6b270c..cf2741f6dd6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Rhys Kenwell <redrield+aur@gmail.com>
# Github Contributor: Michael Herold <https://github.com/michaelherold>
# Github Contributor: ahmubashir <https://github.com/amubashir>
+# Github Contributor: Joey Dumont <https://github.com/joeydumont>
pkgname=heroku-cli
pkgver=7.51.0
-pkgrel=1
+pkgrel=2
_commit_id="b07fb744b68993c2b480f155ef1b4fdd509e77e4"
pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
arch=('any')
url="https://devcenter.heroku.com/articles/heroku-cli"
license=('custom' 'ISC')
depends=('nodejs')
-makedepends=('npm' 'yarn' 'perl' 'git')
+makedepends=('yarn' 'perl' 'git')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-cli-bin' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
source=("git+https://github.com/heroku/cli.git#commit=${_commit_id}")
@@ -45,7 +46,7 @@ prepare() {
pushd "cli"
- # install packaging tools; install fails now unless installed with yarn >:(
+ # install packaging tools
yarn install
pushd packages/cli
@@ -54,7 +55,7 @@ prepare() {
sed -i "/oclif\/plugin-update/d" ./package.json
# install dependencies
- npm install
+ yarn install
# remove dist folder if necessary
if [[ -d "./dist" ]]; then