summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSampson Crowley2021-01-05 15:03:11 -0700
committerSampson Crowley2021-01-05 15:03:11 -0700
commitddfed7e68bbd8cce20c6c29886d5a2bf4007b884 (patch)
treeb766ad309250dcba75c2d038b770508d4755db40
parent657a7cdb520df6466e9710f5c5a357bb36faed9d (diff)
downloadaur-ddfed7e68bbd8cce20c6c29886d5a2bf4007b884.tar.gz
upgpkg: heroku-cli-bin 7.47.7-1
upstream release upgpkg: heroku-cli 7.47.7-1 upstream release heroku-cli 7.47.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9da7a3b7c8a5..2de3487cf59f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = heroku-cli
pkgdesc = CLI to manage Heroku apps and services with forced auto-update removed
- pkgver = 7.47.6
+ pkgver = 7.47.7
pkgrel = 1
url = https://devcenter.heroku.com/articles/heroku-cli
arch = any
license = custom
license = ISC
makedepends = npm
+ makedepends = yarn
makedepends = perl
depends = nodejs
optdepends = git: Deploying to Heroku
@@ -17,9 +18,9 @@ pkgbase = heroku-cli
conflicts = heroku-toolbelt
conflicts = ruby-heroku
options = !strip
- source = https://github.com/heroku/cli/archive/v7.47.6.tar.gz
- sha256sums = 7892f3670771b86be2520b7cc2f4bc6ed3b027a3e05f770e0916d5a1497894ab
- sha512sums = 81661b10491bf1571c1c1b6be973e9fbc45d91b7956cfe7ceadc27ad9d7a55c7bdc05ec97f4ec5cab0d9841108bcef4fb36b00c84d5a372a38f5f0a910f563a9
+ source = https://github.com/heroku/cli/archive/v7.47.7.tar.gz
+ sha256sums = 1d6dfe8c86d7c264b7eab607d77d62c3f29bed24c6b7b08808debed2d77d4bf1
+ sha512sums = 7953df70a2327c675823de3605f8e95e9eb9fc4c7bdb4f01b295e402ea5f7ed5a4f816f1d0e5305f756159637bcba520a28899e3310b208d9283896bb0fb1eec
pkgname = heroku-cli
diff --git a/PKGBUILD b/PKGBUILD
index c473e362d23b..6d55550850d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Github Contributor: Michael Herold <https://github.com/michaelherold>
pkgname=heroku-cli
-pkgver=7.47.6
+pkgver=7.47.7
pkgrel=1
_builddir=cli-$pkgver-$pkgrel
pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
@@ -11,12 +11,22 @@ arch=('any')
url="https://devcenter.heroku.com/articles/heroku-cli"
license=('custom' 'ISC')
depends=('nodejs')
-makedepends=('npm' 'perl')
+# the heroku-cli upstream maintainers live in their own little bubble, so this
+# package now requires both npm and yarn to actually complete the build process.
+#
+# If you need to stick to `npm` the `heroku-cli-bin` works with either/both
+# `npm` and `yarn`, and the package is built through the exact same process,
+# with the exception that it's pre-compiled using my machine before I release
+# it (hence the `-bin` suffix)
+#
+# I have tried every option I can think of to get it to build correctly with
+# pure `npm`; if you have a suggestion I'm all ears
+makedepends=('npm' 'yarn' 'perl')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-cli-bin' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
source=("https://github.com/heroku/cli/archive/v$pkgver.tar.gz")
-sha256sums=('7892f3670771b86be2520b7cc2f4bc6ed3b027a3e05f770e0916d5a1497894ab')
-sha512sums=('81661b10491bf1571c1c1b6be973e9fbc45d91b7956cfe7ceadc27ad9d7a55c7bdc05ec97f4ec5cab0d9841108bcef4fb36b00c84d5a372a38f5f0a910f563a9')
+sha256sums=('1d6dfe8c86d7c264b7eab607d77d62c3f29bed24c6b7b08808debed2d77d4bf1')
+sha512sums=('7953df70a2327c675823de3605f8e95e9eb9fc4c7bdb4f01b295e402ea5f7ed5a4f816f1d0e5305f756159637bcba520a28899e3310b208d9283896bb0fb1eec')
options=('!strip')
provides=('heroku' 'heroku-cli')
@@ -45,7 +55,7 @@ prepare() {
pushd "cli-$pkgver"
# install packaging tools
- npm install
+ yarn
pushd packages/cli