summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSampson Crowley2021-01-05 16:13:36 -0700
committerSampson Crowley2021-01-05 16:13:36 -0700
commitef5f0846c92b2c041a15acc3b98d4bbabce9d300 (patch)
treeb5802ee0487e9a11bb3c85f4c9269622a8601297
parentddfed7e68bbd8cce20c6c29886d5a2bf4007b884 (diff)
downloadaur-ef5f0846c92b2c041a15acc3b98d4bbabce9d300.tar.gz
upgpkg: heroku-cli 7.47.7-2
recompile without nodenv
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2de3487cf59f..c8fc41976b69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = heroku-cli
pkgdesc = CLI to manage Heroku apps and services with forced auto-update removed
pkgver = 7.47.7
- pkgrel = 1
+ pkgrel = 2
url = https://devcenter.heroku.com/articles/heroku-cli
arch = any
license = custom
license = ISC
makedepends = npm
- makedepends = yarn
makedepends = perl
depends = nodejs
optdepends = git: Deploying to Heroku
diff --git a/PKGBUILD b/PKGBUILD
index 6d55550850d6..b9a7c11a6da5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,14 @@
pkgname=heroku-cli
pkgver=7.47.7
-pkgrel=1
+pkgrel=2
_builddir=cli-$pkgver-$pkgrel
pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
arch=('any')
url="https://devcenter.heroku.com/articles/heroku-cli"
license=('custom' 'ISC')
depends=('nodejs')
-# the heroku-cli upstream maintainers live in their own little bubble, so this
-# package now requires both npm and yarn to actually complete the build process.
-#
-# If you need to stick to `npm` the `heroku-cli-bin` works with either/both
-# `npm` and `yarn`, and the package is built through the exact same process,
-# with the exception that it's pre-compiled using my machine before I release
-# it (hence the `-bin` suffix)
-#
-# I have tried every option I can think of to get it to build correctly with
-# pure `npm`; if you have a suggestion I'm all ears
-makedepends=('npm' 'yarn' 'perl')
+makedepends=('npm' 'perl')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-cli-bin' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
source=("https://github.com/heroku/cli/archive/v$pkgver.tar.gz")
@@ -55,7 +45,7 @@ prepare() {
pushd "cli-$pkgver"
# install packaging tools
- yarn
+ npm install
pushd packages/cli