summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2017-09-07 02:56:27 -0400
committerAdam Goldsmith2017-09-07 02:56:27 -0400
commit31e6aed5be0e2963e15c782a98b5831c7b7c2f5a (patch)
tree0534a04f0b2cfd4ab9bced61d302398a4eddd64e
parent265695104bb82042fa349b8f844c861beae06a2d (diff)
downloadaur-31e6aed5be0e2963e15c782a98b5831c7b7c2f5a.tar.gz
Change to "nightly" build
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c462442c2dc..98b266f39202 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
-pkgbase = heroku-cli
+# Generated by mksrcinfo v8
+# Thu Sep 7 06:56:22 UTC 2017
+pkgbase = heroku-cli-nightly
pkgdesc = a tool for creating and managing Heroku apps from the command line
- pkgver = 6.14.16
+ pkgver = 6.14.20.737bba7
pkgrel = 1
url = https://devcenter.heroku.com/articles/heroku-cli
arch = i686
@@ -13,10 +15,10 @@ pkgbase = heroku-cli
conflicts = heroku-client-standalone
conflicts = heroku-toolbelt
conflicts = ruby-heroku
- source_i686 = https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz
- md5sums_i686 = 12d109374a5c7fc9e1d85c86445d09be
- source_x86_64 = https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz
- md5sums_x86_64 = 9e7b3bbf44bb9c2263ccc6ce2c99bfb6
+ source_i686 = heroku-cli.tar-linux.gz::https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz
+ md5sums_i686 = 9ccef74dcbf7e98afbf964b75da8a66f
+ source_x86_64 = heroku-cli-linux.tar.gz::https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz
+ md5sums_x86_64 = 5f19a330f2a3a1f71bc1db3d8f5cf4b3
-pkgname = heroku-cli
+pkgname = heroku-cli-nightly
diff --git a/PKGBUILD b/PKGBUILD
index c1339dd615ba..029557c3eed1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Rhys Kenwell <redrield+aur@gmail.com>
-pkgname=heroku-cli
-pkgver=6.14.16
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+# Based on heroku-cli by Rhys Kenwell <redrield+aur@gmail.com>
+
+pkgname=heroku-cli-nightly
+pkgver=6.14.20.737bba7
pkgrel=1
pkgdesc="a tool for creating and managing Heroku apps from the command line"
arch=('i686' 'x86_64')
@@ -9,24 +11,23 @@ license=('custom' 'ISC')
optdepends=('git: Deploying to Heroku')
provides=('heroku-cli')
conflicts=('heroku-cli' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
-source_x86_64=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz')
-source_i686=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz')
-md5sums_i686=('12d109374a5c7fc9e1d85c86445d09be')
-md5sums_x86_64=('9e7b3bbf44bb9c2263ccc6ce2c99bfb6')
+source_x86_64=('heroku-cli-linux.tar.gz::https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz')
+source_i686=('heroku-cli.tar-linux.gz::https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz')
+md5sums_i686=('9ccef74dcbf7e98afbf964b75da8a66f')
+md5sums_x86_64=('5f19a330f2a3a1f71bc1db3d8f5cf4b3')
-prepare() {
- cd "${srcdir}"
- dir=$(find . -type d -regextype sed -regex ".*/heroku-cli-.*" | head -n1)
- mv $dir heroku-cli
+pkgver() {
+ tar --exclude="*/*" -tf heroku-cli-linux.tar.gz | sed 's|heroku-cli-v\(.*\)-linux-x64/|\1|;s/-/./'
}
package() {
cd "${srcdir}"
+ dir="$(find . -type d -regextype sed -regex ".*/heroku-cli-.*" | head -n1)"
install -dm 755 "${pkgdir}"/opt
install -dm 755 "${pkgdir}"/usr/bin
- install -Dm 644 heroku-cli/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${dir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- mv heroku-cli "${pkgdir}"/opt/heroku-cli
+ cp -r "${dir}" "${pkgdir}"/opt/heroku-cli
ln -s /opt/heroku-cli/bin/heroku "${pkgdir}"/usr/bin/heroku
}