summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2016-01-21 14:36:16 -0300
committerHugo Osvaldo Barrera2016-01-21 14:36:16 -0300
commit2199ad789e0d561488a598d81b291ca6a013cbc8 (patch)
tree668c6187cd8941805184fad0ad8cee30f211071c
parent2dc0612da63221ac63abafa2e4a542250dfdcb8f (diff)
downloadaur-2199ad789e0d561488a598d81b291ca6a013cbc8.tar.gz
Rewrite and update package to 3.42.25
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD37
2 files changed, 24 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b77e755bcb8..2499e2095482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 17:35:44 UTC 2016
pkgbase = heroku-toolbelt
- pkgdesc = Everything you need to get started using Heroku (including foreman)
- pkgver = 3.42.15
+ pkgdesc = Everything you need to get started using Heroku
+ pkgver = 3.42.25
pkgrel = 1
url = https://toolbelt.heroku.com
- arch = any
+ arch = i686
+ arch = x86_64
license = MIT
- license = APACHE
- license = RUBY
- license = PerlArtistic
- license = GPL
- license = custom
- makedepends = ruby-bundler
- depends = ruby>=1.9
optdepends = git
- conflicts = ruby-heroku
- conflicts = ruby-foreman
- conflicts = heroku-client
- source = Gemfile
- source = Gemfile.lock
- sha256sums = f94136836e8f2808bcd2c12cb9d58a4ea42679a05b41e6231efe6475140010f7
- sha256sums = 2204a52cd1fc2abfdc8520ed17592184d495125fda66ef0caaef01d689839ba6
+ conflicts = heroku-client-standalone
+ conflicts = heroku-toolbelt
+ source = https://s3.amazonaws.com/assets.heroku.com/heroku-client/heroku-client-3.42.25.tgz
+ sha256sums = 0394fa11def849d3279969ab503eb6c32f0d81b11735376358d26ba1766ddb56
pkgname = heroku-toolbelt
diff --git a/PKGBUILD b/PKGBUILD
index 29c0bde6c632..74de83466db6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,24 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
-# Contributor: pisuka <tekmon@gmail.com>
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Ranieri Althoff <ranisalt+aur@gmail.com>
pkgname=heroku-toolbelt
-pkgver=3.42.15
+pkgver=3.42.25
pkgrel=1
-pkgdesc="Everything you need to get started using Heroku (including foreman)"
-arch=('any')
+pkgdesc="Everything you need to get started using Heroku"
+arch=('i686' 'x86_64')
url="https://toolbelt.heroku.com"
-license=('MIT' 'APACHE' 'RUBY' 'PerlArtistic' 'GPL' 'custom')
-depends=("ruby>=1.9")
-makedepends=("ruby-bundler")
+license=('MIT')
optdepends=('git')
-conflicts=('ruby-heroku' 'ruby-foreman' 'heroku-client')
-source=('Gemfile' 'Gemfile.lock')
-sha256sums=('f94136836e8f2808bcd2c12cb9d58a4ea42679a05b41e6231efe6475140010f7'
- '2204a52cd1fc2abfdc8520ed17592184d495125fda66ef0caaef01d689839ba6')
+conflicts=('heroku-client-standalone' 'heroku-toolbelt')
+source=("https://s3.amazonaws.com/assets.heroku.com/heroku-client/heroku-client-${pkgver}.tgz")
+sha256sums=('0394fa11def849d3279969ab503eb6c32f0d81b11735376358d26ba1766ddb56')
package() {
- cd "$pkgdir"
- mkdir -p "usr/lib/ruby/vendor_ruby/$pkgname" "usr/bin" "usr/share/man/man1"
- cd "usr/lib/ruby/vendor_ruby/$pkgname"
+ cd "${srcdir}"
- cp -L "$srcdir"/Gemfile* .
+ install -dm 755 "${pkgdir}/usr/local"
+ install -dm 755 "${pkgdir}/usr/bin"
- bundle install --standalone --deployment --binstubs="$pkgdir/usr/bin"
-
- cd "$pkgdir"
-
- find "usr/bin" -type f ! -name heroku ! -name foreman -execdir rm "{}" +
-
- find "usr/lib/ruby/vendor_ruby/heroku-toolbelt/vendor/bundle/ruby" -path "*/gems/*/man/*" -exec ln -st "usr/share/man/man1/" "/{}" \;
+ mv heroku-client "${pkgdir}/usr/local/heroku"
+ ln -s /usr/local/heroku/bin/heroku "${pkgdir}/usr/bin/heroku"
}