summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE2021-10-25 15:24:43 +0200
committerFabien LEFEBVRE2021-10-25 15:24:43 +0200
commit62864ed2e7064cd05b04506f83dea1f8aa29ba01 (patch)
tree26fefb308de3cc7e1ba25891dd0d991da519408c
parent26806ba1d03741b3cf10cb45b2a7036e9df66fda (diff)
downloadaur-62864ed2e7064cd05b04506f83dea1f8aa29ba01.tar.gz
upgpkg: herokuish 0.5.31-2
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD13
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70651dc375cb..8c61ecc8169b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = herokuish
pkgdesc = Utility for emulating Heroku build and runtime tasks in containers
pkgver = 0.5.31
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gliderlabs/herokuish
arch = x86_64
license = MIT
diff --git a/.gitignore b/.gitignore
index 8a68aa486212..f9ecc0a87e76 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-src/
-pkg/
-*.tgz
-*.tar
+/src/
+/pkg/
+/*.tgz
+/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index b8093c0f4168..0f225332e1a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,21 @@
pkgname=herokuish
pkgver=0.5.31
-pkgrel=1
+pkgrel=2
pkgdesc='Utility for emulating Heroku build and runtime tasks in containers'
arch=('x86_64')
url='https://github.com/gliderlabs/herokuish'
license=('MIT')
-
-source=("https://github.com/gliderlabs/herokuish/releases/download/v${pkgver}/herokuish_${pkgver}_linux_x86_64.tgz"
+source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_x86_64.tgz"
'LICENSE')
sha256sums=('db6e341e885dd437500cc701a7a9342c9474fbc6d95819be991fdf9127faaf1e'
'10265a1dd53faef4513b728a16b1eff3e5d5fc0bacc79e692ede34529bb8d1d1')
package() {
- install -Dm 755 herokuish "${pkgdir}/usr/bin/herokuish"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/herokuish/LICENSE"
+ cd "${srcdir}"
+
+ install -Dm755 herokuish "${pkgdir}/usr/bin/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}