summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE (d1ceward)2023-10-24 05:40:26 +0200
committerFabien LEFEBVRE (d1ceward)2023-10-24 05:40:26 +0200
commit733294e18415e939d3753c8d3f3d7c4edd5416f4 (patch)
treef4ff5236f2aef4ae8cb211a477614171773e4467
parenta40c06d41580c6709f6d89842ff53f263af07307 (diff)
downloadaur-733294e18415e939d3753c8d3f3d7c4edd5416f4.tar.gz
upgpkg: herokuish 0.7.2-2
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD39
3 files changed, 39 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 821388013242..29a03008bfd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = herokuish
pkgdesc = Utility for emulating Heroku build and runtime tasks in containers
pkgver = 0.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gliderlabs/herokuish
arch = x86_64
license = MIT
- source = https://github.com/gliderlabs/herokuish/releases/download/v0.7.2/herokuish_0.7.2_linux_x86_64.tgz
- source = LICENSE
- sha256sums = 19fef774c256e25c1d436996fd8146040c4332a1c85c0ca0a1dea8ca7e12a525
- sha256sums = 10265a1dd53faef4513b728a16b1eff3e5d5fc0bacc79e692ede34529bb8d1d1
+ makedepends = go
+ makedepends = go-bindata
+ source = https://github.com/gliderlabs/herokuish/archive/refs/tags/v0.7.2.tar.gz
+ sha256sums = 08e6a8f27f61f3768697de2088cd97af2ca8420fbf4581acca2d6df4f39cd2c6
pkgname = herokuish
diff --git a/.gitignore b/.gitignore
index f9ecc0a87e76..0afc2fb10964 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.tgz
+/*.tar.gz
/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 846b309c8a83..d02ad923507a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,44 @@
pkgname=herokuish
pkgver=0.7.2
-pkgrel=1
+pkgrel=2
pkgdesc='Utility for emulating Heroku build and runtime tasks in containers'
arch=('x86_64')
url='https://github.com/gliderlabs/herokuish'
license=('MIT')
-source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_x86_64.tgz"
- 'LICENSE')
-sha256sums=('19fef774c256e25c1d436996fd8146040c4332a1c85c0ca0a1dea8ca7e12a525'
- '10265a1dd53faef4513b728a16b1eff3e5d5fc0bacc79e692ede34529bb8d1d1')
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('08e6a8f27f61f3768697de2088cd97af2ca8420fbf4581acca2d6df4f39cd2c6')
+makedepends=('go'
+ 'go-bindata')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ # Generate buildpacks info
+ export BUILDPACK_ORDER=$(grep "BUILDPACK_ORDER :=" Makefile | sed 's/BUILDPACK_ORDER := //g')
+ count=0
+ for buildpack in $BUILDPACK_ORDER; do
+ buildpack_count=$(printf '%02d' $count)
+ buildpack_info=$(cat buildpacks/*-${buildpack}/buildpack* | sed 'N;s/\n/ /')
+
+ echo "${buildpack_count}_buildpack-${buildpack} ${buildpack_info}"
+
+ count=$((count + 1))
+ done > include/buildpacks.txt
+ go-bindata include
+
+ # Build executable
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -ldflags "-X main.Version=${pkgver}" -o "${pkgname}-build" .
+}
package() {
- install -Dm755 herokuish "${pkgdir}/usr/bin/${pkgname}"
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm755 herokuish-build "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}