summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authord1ceward2020-04-01 10:28:15 +0200
committerd1ceward2020-04-01 10:28:15 +0200
commit77f6cea1dbfdba8b337562f24f83ba7b94c63d1b (patch)
tree1035ea8caf4db7701a4706e499ed44e850b6f8ae
downloadaur-77f6cea1dbfdba8b337562f24f83ba7b94c63d1b.tar.gz
Add 'herokuish/' from commit '3a890d9459baa68ed9b16fcbc75943344f1e67ab'
git-subtree-dir: herokuish git-subtree-mainline: b4ba35489066103e40d151cbc9d799652d725c21 git-subtree-split: 3a890d9459baa68ed9b16fcbc75943344f1e67ab
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7f6046ce0dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = herokuish
+ pkgdesc = Utility for emulating Heroku build and runtime tasks in containers
+ pkgver = 0.5.8
+ pkgrel = 1
+ url = https://github.com/gliderlabs/herokuish
+ arch = x86_64
+ license = MIT
+ source = https://github.com/gliderlabs/herokuish/releases/download/v0.5.8/herokuish_0.5.8_linux_x86_64.tgz
+ sha256sums = bb081e6f7619af4cf654ebb5e69ac1aba22aa5438ddfbfb741ac736679839765
+
+pkgname = herokuish
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a68aa486212
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tgz
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5a2797dc398
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ayrton Araujo <root@ayr-ton.net>
+# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
+# Contributor: Morris Jobke <hey AT morrisjobke DOT de>
+
+pkgname=herokuish
+pkgver=0.5.8
+pkgrel=1
+pkgdesc='Utility for emulating Heroku build and runtime tasks in containers'
+arch=('x86_64')
+url='https://github.com/gliderlabs/herokuish'
+license=('MIT')
+
+source=("https://github.com/gliderlabs/herokuish/releases/download/v${pkgver}/herokuish_${pkgver}_linux_x86_64.tgz")
+sha256sums=('bb081e6f7619af4cf654ebb5e69ac1aba22aa5438ddfbfb741ac736679839765')
+
+package() {
+ install -Dm 755 herokuish "${pkgdir}/usr/bin/herokuish"
+}