summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2020-12-22 18:40:05 -0800
committerpyamsoft2020-12-22 18:40:05 -0800
commit9c4daed533ab8e5675bf88c5f962c61343a48561 (patch)
treededbfac2942a93677497439979c54c8cbdc5dc03
downloadaur-9c4daed533ab8e5675bf88c5f962c61343a48561.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD65
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbdd7e4725a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = herotate-git
+ pkgdesc = A Heroku multi-login manager for heroku-cli
+ pkgver = r1.13c1ad5
+ pkgrel = 1
+ url = https://github.com/pyamsoft/herotate.git
+ arch = any
+ license = Apachev2.0
+ makedepends = git
+ optdepends = heroku-cli: Heroku CLI
+ provides = herotate
+ conflicts = herotate
+ source = herotate::git+https://github.com/pyamsoft/herotate.git#branch=main
+ sha256sums = SKIP
+
+pkgname = herotate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63ba5065ce99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+##
+# Maintainer: pyamsoft <developer(dot)pyamsoft(at)gmail(dot)com>
+##
+
+_gitname=herotate
+# shellcheck disable=SC2034
+pkgname=herotate-git
+# shellcheck disable=SC2034
+pkgdesc="A Heroku multi-login manager for heroku-cli"
+# shellcheck disable=SC2034
+pkgver=r1.13c1ad5
+# shellcheck disable=SC2034
+pkgrel=1
+# shellcheck disable=SC2034
+arch=('any')
+# shellcheck disable=SC2034
+makedepends=('git')
+# shellcheck disable=SC2034
+depends=()
+# shellcheck disable=SC2034
+optdepends=(
+ 'heroku-cli: Heroku CLI'
+)
+# shellcheck disable=SC2034
+provides=('herotate')
+# shellcheck disable=SC2034
+conflicts=('herotate')
+# shellcheck disable=SC2034
+license=('Apachev2.0')
+url="https://github.com/pyamsoft/herotate.git"
+
+##
+# The SHA256 is constantly changing since this is
+# pulled from git so skip the verification check
+##
+# shellcheck disable=SC2034
+sha256sums=('SKIP')
+# shellcheck disable=SC2034
+source=("${_gitname}::git+${url}#branch=main")
+
+###############################################################################
+
+pkgver() {
+ # shellcheck disable=SC2154
+ cd "$srcdir/$_gitname" || {
+ msg "Could not cd into $srcdir/$_gitname"
+ return 1
+ }
+ # From
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
+ # If there are no tags then use number of revisions since beginning of the history:
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname" || {
+ msg "Could not cd into $srcdir/$_gitname"
+ return 1
+ }
+
+ chmod 755 "${_gitname}"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
+}
+