summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2015-06-14 16:19:43 +0200
committerSteffen Weber2015-06-14 16:19:43 +0200
commit3fa1e8aea4a51a8dcca5996287067ba4e7f09158 (patch)
tree99fd0b67a2ce3768420c719695c1fd3eca9b5227
downloadaur-3fa1e8aea4a51a8dcca5996287067ba4e7f09158.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84b483e6189f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = herrie
+ pkgdesc = Minimalistic music player for the command line
+ pkgver = 2.2
+ pkgrel = 4
+ url = http://herrie.info
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libmodplug
+ depends = libsndfile
+ depends = libid3tag
+ depends = libxspf
+ depends = libmad
+ depends = curl
+ depends = glib2
+ provides = herrie-git
+ conflicts = herrie-git
+ source = http://herrie.info/distfiles/herrie-2.2.tar.bz2
+ md5sums = 88832b10298ab89473730eb0c93b6ddf
+
+pkgname = herrie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c12c3e856a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: juan pablo gonzalez <lord_jotape@yahoo.com.ar>
+
+pkgname=herrie
+pkgver=2.2
+pkgrel=4
+pkgdesc="Minimalistic music player for the command line"
+url="http://herrie.info"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('libmodplug' 'libsndfile' 'libid3tag' 'libxspf' 'libmad' 'curl' 'glib2')
+provides=('herrie-git')
+conflicts=('herrie-git')
+source=($url/distfiles/$pkgname-$pkgver.tar.bz2)
+md5sums=('88832b10298ab89473730eb0c93b6ddf')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i \
+ -e s/spiff/xspf/g \
+ -e s/SPIFF/XSPF/g \
+ -e s/Spiff/Xspf/g \
+ {configure,src/*.c}
+
+ sed -i s!modplug.h!libmodplug/modplug.h! src/audio_format_modplug.c
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+} \ No newline at end of file