summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 14:39:01 +0200
committeraksr2015-06-28 14:39:01 +0200
commit9f0628ed8d3ba174d3a31e57f0c364405f6ed6c2 (patch)
treefa728bee71d2bcf98d018e95396ee39d3aaa9707
downloadaur-9f0628ed8d3ba174d3a31e57f0c364405f6ed6c2.tar.gz
Start.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--make-install.patch18
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc685735ec6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = hessling-editor-das
+ pkgdesc = A powerful text editor modelled on the VM/CMS text editor XEDIT with the best features of Mansfield Software's Kedit.
+ pkgver = 3.3RC1
+ pkgrel = 2
+ url = http://hessling-editor.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ depends = regina-rexx-das
+ provides = hessling-editor
+ options = !buildflags
+ source = http://downloads.sourceforge.net/hessling-editor/THE-3.3RC1.tar.gz
+ source = make-install.patch
+ md5sums = e46b63e533bc458f6f701983b7f2150b
+ md5sums = e7898d1e8ac920e972f1dc7d660db1e0
+ sha1sums = a7f0957f077e836ee783d797e424de48e3142b38
+ sha1sums = 0aa2657a6375ce8a727ad36a812c613b9ac6a788
+ sha256sums = dcc1a67c0da5a009ac03e398cf683757a2d2c84081d56da2ddc073fbec48ea38
+ sha256sums = 6b4bbcb6ae2b85ebe3e95713c07ebfc4eede44363cfce89869186163e089d4cf
+
+pkgname = hessling-editor-das
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..768f5e0f350c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+#Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+#Contributor: Dwight Schauer <dschauer@gmail.com>
+#Contributor: GdelaRey <arch at delarey dot org>
+#Maintainer: aksr <aksr at t-com dot me>
+_pkgname=THE
+pkgname=hessling-editor-das
+pkgver=3.3RC1
+pkgrel=2
+pkgdesc="A powerful text editor modelled on the VM/CMS text editor XEDIT with the best features of Mansfield Software's Kedit."
+arch=('i686' 'x86_64')
+url="http://hessling-editor.sourceforge.net/"
+license=('GPL')
+depends=('ncurses' 'regina-rexx-das')
+provides=('hessling-editor')
+options=(!buildflags)
+source=("http://downloads.sourceforge.net/$provides/$_pkgname-$pkgver.tar.gz"
+ 'make-install.patch')
+md5sums=('e46b63e533bc458f6f701983b7f2150b'
+ 'e7898d1e8ac920e972f1dc7d660db1e0')
+sha1sums=('a7f0957f077e836ee783d797e424de48e3142b38'
+ '0aa2657a6375ce8a727ad36a812c613b9ac6a788')
+sha256sums=('dcc1a67c0da5a009ac03e398cf683757a2d2c84081d56da2ddc073fbec48ea38'
+ '6b4bbcb6ae2b85ebe3e95713c07ebfc4eede44363cfce89869186163e089d4cf')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -Np1 -i $srcdir/make-install.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ unset CFLAGS CXXFLAGS LDFLAGS
+ ./configure --with-rexx=regina --with-ncurses --prefix=/usr
+ make nthe
+ make the.man
+ make THE_Help.txt
+}
+
+package(){
+ make -C "$_pkgname-$pkgver" DESTDIR=$pkgdir install
+ ln -s nthe "$pkgdir/usr/bin/the"
+}
+
diff --git a/make-install.patch b/make-install.patch
new file mode 100644
index 000000000000..9398bbad5298
--- /dev/null
+++ b/make-install.patch
@@ -0,0 +1,18 @@
+--- THE-3.3RC1/Makefile.in 2011-07-11 10:55:57.000000000 +0000
++++ THE-3.3RC1-new/Makefile.in 2012-05-01 10:33:15.038067291 +0000
+@@ -285,14 +285,13 @@
+
+ uninstall: un$(BASE_INSTALL)
+
+-installbase: $(THEBIN) the the.man THE_Help.txt installrpm installdoc
++installbase: $(THEBIN) the.man THE_Help.txt installrpm installdoc
+
+ uninstallbase: uninstallrpm uninstalldoc
+
+ installrpm: $(THEBIN)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) -m 755 -c ./$(THEBIN) $(DESTDIR)$(bindir)/$(THEBIN)
+- $(INSTALL) -m 755 -c ./the $(DESTDIR)$(bindir)/the
+
+ uninstallrpm: $(THEBIN)
+ -rm -f $(DESTDIR)$(bindir)/$(THEBIN)