summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Reddehase2015-09-06 13:26:01 +0000
committerTim Reddehase2015-09-06 13:27:33 +0000
commitacfcb8216d78bea28a78dde05d5c2505912dae47 (patch)
treec036ecaff556fb3c046dce965941fd57a04ce0fb
downloadaur-acfcb8216d78bea28a78dde05d5c2505912dae47.tar.gz
initial commit w/ current version.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD27
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d791790d44b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = hets
+ pkgdesc = A parsing, static analysis and proof management tool incorporating various provers and different specification languages, thus providing a tool for heterogeneous specifications. Logic translations are first-class citizens.
+ pkgver = 0.99_1441029199
+ pkgrel = 2
+ url = http://www.informatik.uni-bremen.de/agbkb/forschung/formal_methods/CoFI/hets/index_e.htm
+ arch = x86_64
+ license = custom:hets-license
+ depends = ghc
+ depends = udrawgraph
+ depends = tcl
+ depends = tk
+ depends = spass
+ depends = ncurses
+ depends = pellet
+ depends = cairo
+ depends = glib2
+ depends = gtk2
+ depends = gettext
+ depends = fontconfig
+ depends = libglade
+ depends = darwin
+ depends = eprover
+ optdepends = isabelle
+ provides = hets
+ conflicts = hets
+ source = http://ontohub.rightsrestricted.com/hets/binaries/hets-0.99_1441029199.tar.gz
+ sha1sums = ec09b17e0016245a4487263fb1e2c0ca07affd56
+
+pkgname = hets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c8531b90d6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tim Reddehase <robustus@rightsrestricted.com>
+
+pkgname=hets
+pkgver=0.99_1441029199
+pkgrel=2
+
+pkgdesc="A parsing, static analysis and proof management tool incorporating various provers and different specification languages, thus providing a tool for heterogeneous specifications. Logic translations are first-class citizens."
+
+url="http://www.informatik.uni-bremen.de/agbkb/forschung/formal_methods/CoFI/hets/index_e.htm"
+arch=('x86_64')
+license='custom:hets-license'
+depends=('ghc' 'udrawgraph' 'tcl' 'tk' 'spass' 'ncurses' 'pellet' 'cairo' 'glib2' 'gtk2' 'gettext' 'fontconfig' 'libglade' 'darwin' 'eprover')
+optdepends=('isabelle')
+provides=('hets')
+conflicts=('hets')
+sha1sums=('ec09b17e0016245a4487263fb1e2c0ca07affd56')
+source=("http://ontohub.rightsrestricted.com/hets/binaries/hets-${pkgver}.tar.gz")
+package() {
+ cd ${srcdir}
+
+ mkdir -p ${pkgdir}/opt/hets/
+ mkdir -p ${pkgdir}/usr/bin/
+
+ mv ${srcdir}/hets-${pkgver}/bin/hets ${pkgdir}/usr/bin/hets
+
+ cp -r ${srcdir}/hets-${pkgver}/* ${pkgdir}/opt/hets/
+}