summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugen Kuksa2016-08-18 12:53:41 +0200
committerEugen Kuksa2016-08-18 12:53:41 +0200
commit749719612c61bb1a459589d9844cf7b7cc40f80a (patch)
tree618f2eac35e2e37dd81d2ce33e5f614ff8094ae6
downloadaur-749719612c61bb1a459589d9844cf7b7cc40f80a.tar.gz
Switch to self-builing Hets.
-rw-r--r--.SRCINFO33
-rwxr-xr-xPKGBUILD57
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cea7804cddf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Thu Aug 18 10:53:17 UTC 2016
+pkgbase = hets-desktop
+ pkgdesc = A parsing, static analysis and proof management tool incorporating various provers and different specification languages.
+ pkgver = 0.99_1471209385
+ pkgrel = 1
+ url = http://hets.eu
+ arch = i686
+ arch = x86_64
+ license = custom:hets-license
+ makedepends = ghc>=7.8.4
+ depends = hets-commons
+ depends = hets-lib
+ depends = tcl
+ depends = tk
+ depends = ncurses
+ depends = cairo
+ depends = glib2
+ depends = gettext
+ depends = fontconfig
+ depends = libglade
+ optdepends = spass
+ optdepends = eprover
+ optdepends = darwin
+ optdepends = pellet
+ optdepends = isabelle
+ provides = hets-dekstop
+ conflicts = hets-dekstop-bin
+ source = hets-desktop::git+https://github.com/spechub/Hets.git#commit=9c020bf240dace07c6defccb1c8a42328ec454e0
+ sha256sums = SKIP
+
+pkgname = hets-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a98c2462eb40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Eugen Kuksa <eugenk@cs.uni-bremen.de>
+
+pkgname=hets-desktop
+pkgver=0.99_1471209385
+pkgrel=1
+
+pkgdesc="A parsing, static analysis and proof management tool incorporating various provers and different specification languages."
+
+url="http://hets.eu"
+arch=('i686' 'x86_64')
+license=('custom:hets-license')
+depends=('hets-commons' 'hets-lib' 'tcl' 'tk' 'ncurses' 'cairo' 'glib2' 'gettext' 'fontconfig' 'libglade')
+optdepends=('spass' 'eprover' 'darwin' 'pellet' 'isabelle')
+makedepends=('ghc>=7.8.4')
+provides=('hets-dekstop')
+conflicts=('hets-dekstop-bin')
+_commit='9c020bf240dace07c6defccb1c8a42328ec454e0'
+source=("${pkgname}::git+https://github.com/spechub/Hets.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+_executable_name='hets'
+
+build() {
+ cd $srcdir/$pkgname
+ make hets.bin
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make install-hets PREFIX="$pkgdir/usr"
+
+ # Patch the header of the wrapper script to include the (only working) locale,
+ # to use a shell that is certainly installed and to set the correct basedir.
+ local wrapper_script="bin/$_executable_name"
+ pushd "$pkgdir/usr" > /dev/null
+ # Remove useless files that were added by the makefile's sed invocation
+ rm -f "share/man/man1/hets.1e"
+ rm -f "share/man/man1/hets.1-e"
+
+ echo "#!/bin/bash" > "$wrapper_script.tmp"
+ echo "" >> "$wrapper_script.tmp"
+ echo "export LANG=en_US.UTF-8" >> "$wrapper_script.tmp"
+ echo "export LANGUAGE=en_US.UTF-8" >> "$wrapper_script.tmp"
+ echo "export LC_ALL=en_US.UTF-8" >> "$wrapper_script.tmp"
+ echo "" >> "$wrapper_script.tmp"
+ echo "BASEDIR=\"/usr\"" >> "$wrapper_script.tmp"
+ echo "PROG=\"$_executable_name\"" >> "$wrapper_script.tmp"
+
+ # replace the script header with the above one
+ sed -ie "/\/bin\/ksh93/,/PROG=/ d" "$wrapper_script"
+ cat "$wrapper_script" >> "$wrapper_script.tmp"
+ cat "$wrapper_script.tmp" > "$wrapper_script"
+ rm -f "${wrapper_script}.tmp"
+ rm -f "${wrapper_script}e"
+ rm -f "${wrapper_script}-e"
+ popd > /dev/null
+}