summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2015-08-11 13:22:29 +0300
committerAndrey Vihrov2015-08-11 13:22:29 +0300
commit43f5ce8d2b37c59a87af38e5142edee8c228bb4e (patch)
treed2e352e31094741f64615e6c7209265e04c66762
parentef10daf6d0d1c9828f3626e6ff6feb4a30c3ff47 (diff)
downloadaur-43f5ce8d2b37c59a87af38e5142edee8c228bb4e.tar.gz
Bump version, use CMake for building
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d66866026dae..b6f0f99de242 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = hexchat-autoaway
pkgdesc = A HexChat plugin to set away on idle
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
url = https://github.com/andreyv/hexchat-autoaway
arch = i686
arch = x86_64
license = GPL3
+ makedepends = cmake
depends = hexchat
depends = libxss
conflicts = hexchat-autoaway-git
- source = https://github.com/andreyv/hexchat-autoaway/archive/v1.0.2.tar.gz
- sha256sums = afd78ff8777f162e634d97804787ad8ff9928a3e16d8ef659d0d93b49518b252
+ source = https://github.com/andreyv/hexchat-autoaway/archive/v1.0.3.tar.gz
+ sha256sums = 35367a4e0d6f1c83ec36f2ae11d9274cd874aa990f69c8b8690cca4045709e80
pkgname = hexchat-autoaway
diff --git a/PKGBUILD b/PKGBUILD
index 06e28afaf4ba..e21ef12ca75f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
pkgname=hexchat-autoaway
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="A HexChat plugin to set away on idle"
arch=('i686' 'x86_64')
url="https://github.com/andreyv/hexchat-autoaway"
license=('GPL3')
depends=('hexchat' 'libxss')
+makedepends=('cmake')
conflicts=('hexchat-autoaway-git')
source=("https://github.com/andreyv/hexchat-autoaway/archive/v$pkgver.tar.gz")
-sha256sums=('afd78ff8777f162e634d97804787ad8ff9928a3e16d8ef659d0d93b49518b252')
+sha256sums=('35367a4e0d6f1c83ec36f2ae11d9274cd874aa990f69c8b8690cca4045709e80')
build() {
cd "${pkgname}-${pkgver}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
make
}
package() {
cd "${pkgname}-${pkgver}"
- install -D autoaway.so "$pkgdir/usr/lib/hexchat/plugins/autoaway.so"
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: