summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2015-06-14 10:30:47 +0300
committerAndrey Vihrov2015-06-14 10:30:47 +0300
commitef10daf6d0d1c9828f3626e6ff6feb4a30c3ff47 (patch)
tree4230f6ca3fd0a666f2981ccd1321c9fdf080e8f3
downloadaur-ef10daf6d0d1c9828f3626e6ff6feb4a30c3ff47.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d66866026dae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hexchat-autoaway
+ pkgdesc = A HexChat plugin to set away on idle
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/andreyv/hexchat-autoaway
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = hexchat
+ depends = libxss
+ conflicts = hexchat-autoaway-git
+ source = https://github.com/andreyv/hexchat-autoaway/archive/v1.0.2.tar.gz
+ sha256sums = afd78ff8777f162e634d97804787ad8ff9928a3e16d8ef659d0d93b49518b252
+
+pkgname = hexchat-autoaway
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06e28afaf4ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
+
+pkgname=hexchat-autoaway
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A HexChat plugin to set away on idle"
+arch=('i686' 'x86_64')
+url="https://github.com/andreyv/hexchat-autoaway"
+license=('GPL3')
+depends=('hexchat' 'libxss')
+conflicts=('hexchat-autoaway-git')
+source=("https://github.com/andreyv/hexchat-autoaway/archive/v$pkgver.tar.gz")
+sha256sums=('afd78ff8777f162e634d97804787ad8ff9928a3e16d8ef659d0d93b49518b252')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -D autoaway.so "$pkgdir/usr/lib/hexchat/plugins/autoaway.so"
+}
+
+# vim:set ts=2 sw=2 et: