summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBakasura2019-09-15 21:04:39 -0500
committerBakasura2019-09-15 21:04:39 -0500
commit28db6f3099c69f913896017511dd0f522b4a5878 (patch)
tree542fb9c786a8c54b2dc4e3226867470ec6de77ca
downloadaur-28db6f3099c69f913896017511dd0f522b4a5878.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b66a608a54c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hexchat-fishlim-reloaded-git
+ pkgdesc = FiSHLiM support to HexChat with with steroids!
+ pkgver = r4.4a8f9ab
+ pkgrel = 1
+ url = https://github.com/BakasuraRCE/hexchat-fishlim-reloaded
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = hexchat
+ depends = openssl>=0.9.8
+ provides = hexchat-fishlim-reloaded
+ conflicts = hexchat-fishlim-reloaded
+ source = hexchat-fishlim-reloaded-git::git+https://github.com/BakasuraRCE/hexchat-fishlim-reloaded
+ sha256sums = SKIP
+
+pkgname = hexchat-fishlim-reloaded-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..942fe02b1a6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bakasura <bakasura@protonmail.ch>
+
+pkgname=hexchat-fishlim-reloaded-git
+pkgver=r4.4a8f9ab
+pkgrel=1
+pkgdesc="FiSHLiM support to HexChat with with steroids!"
+url="https://github.com/BakasuraRCE/hexchat-fishlim-reloaded"
+license=('GPL3')
+arch=('i686' 'x86_64')
+depends=('hexchat' 'openssl>=0.9.8')
+makedepends=('git' 'meson')
+conflicts=('hexchat-fishlim-reloaded')
+provides=('hexchat-fishlim-reloaded')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname}"
+ arch-meson build -D local_install=false
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+