summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Vybíhal2018-12-17 10:02:41 +0100
committerJosef Vybíhal2018-12-17 10:02:41 +0100
commitcb6478a754d21508d9cdd47682aef5540ac62cb5 (patch)
treed9387601ce35697bd9a2752937aa2197427b97db
parent7ce3527bf98be521b1c5143260d2123550de70af (diff)
downloadaur-cb6478a754d21508d9cdd47682aef5540ac62cb5.tar.gz
Small rewite by new maintainer.
Mostly to match offcial hexchat package https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/hexchat Added python2 line, because I need to compile with python2 support for now.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD33
2 files changed, 37 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3327ecbf93f..c065f38b87e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hexchat-git
pkgdesc = A GTK+ based IRC client
- pkgver = 2.12.4.r45.gc6f3fbd1
+ pkgver = 2.14.2.r9.ged553301
pkgrel = 1
url = https://hexchat.github.io
arch = i686
@@ -8,28 +8,32 @@ pkgbase = hexchat-git
arch = armv6h
license = GPL
makedepends = git
+ makedepends = intltool
+ makedepends = iso-codes
+ makedepends = lua
+ makedepends = meson
makedepends = perl
makedepends = python
- makedepends = meson
- depends = gtk2
- depends = openssl
depends = dbus-glib
- depends = luajit
+ depends = desktop-file-utils
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk2
depends = libcanberra
depends = libnotify
depends = libproxy
- depends = hicolor-icon-theme
- depends = desktop-file-utils
- depends = sound-theme-freedesktop
- depends = iso-codes
- optdepends = enchant: for spell check
- optdepends = perl: for perl plugin
- optdepends = python: for python plugin
+ depends = openssl
+ depends = pango
+ depends = pciutils
+ optdepends = enchant: Spell check
+ optdepends = iso-codes: Display language names instead of codes
+ optdepends = lua: Lua plugin
+ optdepends = perl: Perl plugin
+ optdepends = python: Python plugin
provides = hexchat
conflicts = hexchat
conflicts = hexchat-lua-git
replaces = hexchat-lua-git
- options = !libtool
source = git://github.com/hexchat/hexchat.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 82a002fcb98f..f5cc7059fd8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: TingPing tingping@tingping.se
+# Maintainer: Josef Vybihal josef.vybihal.gmail.com
+# Previous maintainer: TingPing tingping@tingping.se
pkgname=hexchat-git
-pkgver=2.12.4.r45.gc6f3fbd1
+pkgver=2.14.2.r9.ged553301
pkgrel=1
pkgdesc='A GTK+ based IRC client'
arch=('i686' 'x86_64' 'armv6h')
url='https://hexchat.github.io'
license=('GPL')
-depends=('gtk2' 'openssl' 'dbus-glib' 'luajit'
- 'libcanberra' 'libnotify' 'libproxy'
- 'hicolor-icon-theme' 'desktop-file-utils' 'sound-theme-freedesktop' 'iso-codes')
-makedepends=('git' 'perl' 'python' 'meson')
-optdepends=('enchant: for spell check'
- 'perl: for perl plugin'
- 'python: for python plugin')
+depends=('dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gtk2'
+ 'libcanberra' 'libnotify' 'libproxy' 'openssl' 'pango' 'pciutils')
+makedepends=('git' 'intltool' 'iso-codes' 'lua' 'meson' 'perl' 'python')
+optdepends=('enchant: Spell check'
+ 'iso-codes: Display language names instead of codes'
+ 'lua: Lua plugin'
+ 'perl: Perl plugin'
+ 'python: Python plugin')
provides=('hexchat')
conflicts=('hexchat' 'hexchat-lua-git')
replaces=('hexchat-lua-git')
@@ -28,14 +30,19 @@ pkgver() {
}
build() {
- cd "$_gitname"
+ #cd "$_gitname"
- rm -rf _build
- meson _build --prefix=/usr --buildtype=plain
+ #rm -rf _build
+ arch-meson ${_gitname} _build \
+ --prefix=/usr \
+ --buildtype=plain \
+ -Dwith-lua='lua' \
+ -Dwith-text='true' \
+ #-Dwith-python=python2
ninja -C _build
}
package() {
- cd "$_gitname"
+ #cd "$_gitname"
env DESTDIR="$pkgdir" ninja -C _build install
}