summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-08 20:17:58 -0400
committerXiao-Long Chen2015-06-08 20:17:58 -0400
commitb6bd7a11e5e84fa6c55a19cb7dc30f12b5ecab83 (patch)
tree8ce0c2fccc61de745722bc3024fe3de24cbfec33
downloadaur-b6bd7a11e5e84fa6c55a19cb7dc30f12b5ecab83.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e23a2e6af46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hexchat-indicator
+ pkgdesc = Unity Application Indicator for HexChat (Bazaar version)
+ pkgver = 3
+ pkgrel = 1
+ url = https://launchpad.net/hexchat-indicator/trunk
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = bzr
+ depends = indicator-messages
+ depends = libunity
+ source = hexchat-indicator::bzr+lp:hexchat-indicator
+ sha512sums = SKIP
+
+pkgname = hexchat-indicator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5e675b19dd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=hexchat-indicator
+pkgver=3
+pkgrel=1
+pkgdesc="Unity Application Indicator for HexChat (Bazaar version)"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/hexchat-indicator/trunk"
+license=('GPL')
+depends=('indicator-messages' 'libunity')
+makedepends=('bzr')
+source=('hexchat-indicator::bzr+lp:hexchat-indicator')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd hexchat-indicator
+ echo "$(bzr revno)"
+}
+
+build() {
+ cd hexchat-indicator
+ autoreconf -vfi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd hexchat-indicator
+ make DESTDIR="${pkgdir}/" install
+}