summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuel Serpa2020-02-01 15:22:22 -0300
committerEmanuel Serpa2020-02-01 15:22:22 -0300
commit5f6371b65753ec86726b33c9488451652334b9f8 (patch)
tree3e1ed49d3ee4e4261540bfcf9513ab910bd99291
parentf0378250c5580adb5a01dfaf8a5199512ed93aa7 (diff)
downloadaur-5f6371b65753ec86726b33c9488451652334b9f8.tar.gz
...
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 23 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef333c7a22f7..4062658c6798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = hexchat-python2
- pkgdesc = A popular and easy to use graphical IRC (chat) client, with python2 support
- pkgver = 2.12.4
+ pkgdesc = A popular and easy to use graphical IRC (chat) client, with python2 support.
+ pkgver = 2.14.3
pkgrel = 1
url = https://hexchat.github.io/
- arch = i686
arch = x86_64
license = GPL
+ makedepends = git
makedepends = intltool
makedepends = iso-codes
makedepends = lua
+ makedepends = meson
makedepends = perl
makedepends = python2
- makedepends = autoconf-archive
depends = dbus-glib
depends = desktop-file-utils
depends = gdk-pixbuf2
depends = glib2
- depends = glibc
depends = gtk2
depends = libcanberra
depends = libnotify
@@ -28,13 +27,12 @@ pkgbase = hexchat-python2
optdepends = iso-codes: Display language names instead of codes
optdepends = lua: Lua plugin
optdepends = perl: Perl plugin
- optdepends = python: Python plugin
- provides = hexchat
+ optdepends = python2: Python plugin
conflicts = hexchat
conflicts = hexchat-git
conflicts = hexchat-lua-git
- source = https://dl.hexchat.net/hexchat/hexchat-2.12.4.tar.xz
- sha256sums = fa35913158bbc7d0d99de79371b6df3e8d21802f1d2c7c92f0e5db694acf2c3a
+ source = git+https://github.com/hexchat/hexchat.git#tag=v2.14.3
+ sha256sums = SKIP
pkgname = hexchat-python2
diff --git a/PKGBUILD b/PKGBUILD
index 18c7084c5f28..7f751bdba8f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
# Maintainer: Emanuel Serpa <emanuelserpa@alu.ufc.br>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: TingPing <tingping@tingping.se>
-
pkgname=hexchat-python2
-pkgver=2.12.4
+pkgver=2.14.3
pkgrel=1
-pkgdesc='A popular and easy to use graphical IRC (chat) client, with python2 support'
-arch=('i686' 'x86_64')
+pkgdesc='A popular and easy to use graphical IRC (chat) client, with python2 support.'
+arch=('x86_64')
url='https://hexchat.github.io/'
license=('GPL')
-provides=('hexchat')
conflicts=('hexchat' 'hexchat-git' 'hexchat-lua-git')
-depends=('dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk2'
+depends=('dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'gtk2'
'libcanberra' 'libnotify' 'libproxy' 'openssl' 'pango' 'pciutils')
-makedepends=('intltool' 'iso-codes' 'lua' 'perl' 'python2' 'autoconf-archive')
+makedepends=('git' 'intltool' 'iso-codes' 'lua' 'meson' 'perl' 'python2')
optdepends=('enchant: Spell check'
'iso-codes: Display language names instead of codes'
'lua: Lua plugin'
'perl: Perl plugin'
- 'python: Python plugin')
-source=("https://dl.hexchat.net/hexchat/hexchat-${pkgver}.tar.xz")
-sha256sums=('fa35913158bbc7d0d99de79371b6df3e8d21802f1d2c7c92f0e5db694acf2c3a')
-
+ 'python2: Python plugin')
+source=("git+https://github.com/hexchat/hexchat.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cd hexchat-${pkgver}
-
- ./configure \
- --prefix='/usr' \
- --enable-python='python2' \
- --enable-textfe
- make
+ arch-meson hexchat build \
+ -Dwith-lua='lua' \
+ -Dwith-text='true' \
+ -Dwith-python='python2'
+ ninja -C build
}
package() {
- cd hexchat-${pkgver}
-
- make DESTDIR="${pkgdir}" install
+ mkdir -p ${pkgdir}/usr/lib/hexchat/plugins
+ install -m644 ${srcdir}/build/plugins/python/python.so ${pkgdir}/usr/lib/hexchat/plugins/python2.so
}
-# vim: ts=2 sw=2 et:
+# vim: ts=2 sw=2 et