summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordeathye2017-09-09 04:37:45 -0300
committerdeathye2017-09-09 04:37:45 -0300
commitf0378250c5580adb5a01dfaf8a5199512ed93aa7 (patch)
treed17eb4dd3b259d93a8a9148646d4323a1ff4636d
downloadaur-f0378250c5580adb5a01dfaf8a5199512ed93aa7.tar.gz
...
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD42
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef333c7a22f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = hexchat-python2
+ pkgdesc = A popular and easy to use graphical IRC (chat) client, with python2 support
+ pkgver = 2.12.4
+ pkgrel = 1
+ url = https://hexchat.github.io/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = iso-codes
+ makedepends = lua
+ makedepends = perl
+ makedepends = python2
+ makedepends = autoconf-archive
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk2
+ depends = libcanberra
+ depends = libnotify
+ depends = libproxy
+ depends = openssl
+ depends = pango
+ depends = pciutils
+ optdepends = enchant: Spell check
+ optdepends = iso-codes: Display language names instead of codes
+ optdepends = lua: Lua plugin
+ optdepends = perl: Perl plugin
+ optdepends = python: Python plugin
+ provides = hexchat
+ conflicts = hexchat
+ conflicts = hexchat-git
+ conflicts = hexchat-lua-git
+ source = https://dl.hexchat.net/hexchat/hexchat-2.12.4.tar.xz
+ sha256sums = fa35913158bbc7d0d99de79371b6df3e8d21802f1d2c7c92f0e5db694acf2c3a
+
+pkgname = hexchat-python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18c7084c5f28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Emanuel Serpa <emanuelserpa@alu.ufc.br>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: TingPing <tingping@tingping.se>
+
+pkgname=hexchat-python2
+pkgver=2.12.4
+pkgrel=1
+pkgdesc='A popular and easy to use graphical IRC (chat) client, with python2 support'
+arch=('i686' 'x86_64')
+url='https://hexchat.github.io/'
+license=('GPL')
+provides=('hexchat')
+conflicts=('hexchat' 'hexchat-git' 'hexchat-lua-git')
+depends=('dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk2'
+ 'libcanberra' 'libnotify' 'libproxy' 'openssl' 'pango' 'pciutils')
+makedepends=('intltool' 'iso-codes' 'lua' 'perl' 'python2' 'autoconf-archive')
+optdepends=('enchant: Spell check'
+ 'iso-codes: Display language names instead of codes'
+ 'lua: Lua plugin'
+ 'perl: Perl plugin'
+ 'python: Python plugin')
+source=("https://dl.hexchat.net/hexchat/hexchat-${pkgver}.tar.xz")
+sha256sums=('fa35913158bbc7d0d99de79371b6df3e8d21802f1d2c7c92f0e5db694acf2c3a')
+
+
+build() {
+ cd hexchat-${pkgver}
+
+ ./configure \
+ --prefix='/usr' \
+ --enable-python='python2' \
+ --enable-textfe
+ make
+}
+
+package() {
+ cd hexchat-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: