summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Griffis2016-08-27 22:12:36 -0400
committerPatrick Griffis2016-08-27 22:12:36 -0400
commit26c322c495ebc8e38c2b0a341c5bf86753a2dd85 (patch)
treee2dc0b222c1462c5cf99c98f956b2613d72747fd
parent9cc66864a8f12b39b8ebff7d9c02f63b419cae48 (diff)
downloadaur-26c322c495ebc8e38c2b0a341c5bf86753a2dd85.tar.gz
Update
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD42
-rw-r--r--htm-mime.xml7
-rw-r--r--htm.desktop7
-rwxr-xr-xhtm.install13
5 files changed, 29 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c924d9dac1b1..aa64bd7aa94f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
pkgbase = hexchat-theme-manager
pkgdesc = A simple application to manage HexChat themes
- pkgver = 2.9.5
+ pkgver = 2.12.1
pkgrel = 1
- url = http://www.hexchat.org/
- install = htm.install
+ url = https://hexchat.github.io
arch = i686
arch = x86_64
license = GPL
makedepends = monodevelop
depends = mono
depends = hexchat
- source = http://dl.hexchat.net/hexchat/hexchat-2.9.5.tar.xz
- source = htm.desktop
- source = htm-mime.xml
- sha256sums = 11dfd0fbfb88d8dbb38f631fab8a7dffbb179f7f7dafe316953ed6f513ac623d
- sha256sums = 1de36ac0a1fb72cef845e555635f221e72130c4afe7e3fe1c326cc0872f61c8d
- sha256sums = 54e4a4ed2472e2ccf34df7a2f3c8f1aca0b2b4f68687969672c9e70a1e3cbef5
+ source = https://dl.hexchat.net/hexchat/hexchat-2.12.1.tar.xz
+ sha256sums = 5201b0c6d17dcb8c2cb79e9c39681f8e052999ba8f7b5986d5c1e7dc68fa7c6b
pkgname = hexchat-theme-manager
diff --git a/PKGBUILD b/PKGBUILD
index 02afa7575c83..892dfa88f394 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,40 @@
# Maintainer: TingPing <tingping@tingping.se>
pkgname=hexchat-theme-manager
-pkgver=2.9.5
+pkgver=2.12.1
pkgrel=1
-pkgdesc="A simple application to manage HexChat themes"
+pkgdesc='A simple application to manage HexChat themes'
arch=('i686' 'x86_64')
-url='http://www.hexchat.org/'
+url='https://hexchat.github.io'
license=('GPL')
depends=('mono' 'hexchat')
makedepends=('monodevelop')
-optdepends=()
-options=()
-install='htm.install'
-source=("http://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz"
- 'htm.desktop' 'htm-mime.xml')
-sha256sums=('11dfd0fbfb88d8dbb38f631fab8a7dffbb179f7f7dafe316953ed6f513ac623d'
- '1de36ac0a1fb72cef845e555635f221e72130c4afe7e3fe1c326cc0872f61c8d'
- '54e4a4ed2472e2ccf34df7a2f3c8f1aca0b2b4f68687969672c9e70a1e3cbef5')
+source=("https://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz")
+sha256sums=('5201b0c6d17dcb8c2cb79e9c39681f8e052999ba8f7b5986d5c1e7dc68fa7c6b')
build() {
- cd "$srcdir/hexchat-$pkgver/src/htm"
- mdtool build htm-mono.csproj
+ cd "hexchat-$pkgver"
+
+ # This builds more than necessary but oh well
+ ./configure --prefix=/usr --with-theme-manager \
+ --disable-gtkfe --disable-plugin --disable-dbus --disable-nls
+ make
}
package() {
- cd "$srcdir/hexchat-$pkgver/src/htm"
- install -D thememan.exe "$pkgdir/usr/bin/thememan"
- install -D "$srcdir/htm.desktop" "$pkgdir/usr/share/applications/htm.desktop"
- install -D "$srcdir/htm-mime.xml" "$pkgdir/usr/share/mime/packages/htm.xml"
+ cd "hexchat-$pkgver"
+
+ # TODO: Fix this upstream
+
+ pushd data/misc
+ make install DESTDIR="$pkgdir"
+ popd
+
+ pushd src/htm
+ make install DESTDIR="$pkgdir"
+ popd
+
+ rm -r "$pkgdir/usr/share/appdata"
+ rm "$pkgdir/usr/share/applications/hexchat.desktop"
}
diff --git a/htm-mime.xml b/htm-mime.xml
deleted file mode 100644
index 1201aaf34457..000000000000
--- a/htm-mime.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0"?>
- <mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
- <mime-type type="application/x-hct">
- <comment>HexChat theme archives</comment>
- <glob pattern="*.hct"/>
- </mime-type>
- </mime-info>
diff --git a/htm.desktop b/htm.desktop
deleted file mode 100644
index 7651c91f108a..000000000000
--- a/htm.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=HexChat Theme Manager
-Exec=mono /usr/bin/thememan %f
-Icon=hexchat
-Terminal=false
-Type=Application
-MimeType=application/x-hct
diff --git a/htm.install b/htm.install
deleted file mode 100755
index 564381a0210a..000000000000
--- a/htm.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- update-desktop-database -q
- update-mime-database usr/share/mime
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-