summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Griffis2016-10-10 13:24:38 -0400
committerPatrick Griffis2016-10-10 13:25:00 -0400
commit7d08a6ee8560976905191531eb1303420040a47c (patch)
treefe00d4733fc8c8a797dca4a350dc6627d5262a8d
parent26c322c495ebc8e38c2b0a341c5bf86753a2dd85 (diff)
downloadaur-7d08a6ee8560976905191531eb1303420040a47c.tar.gz
Bump version
-rw-r--r--.SRCINFO6
-rw-r--r--[-rwxr-xr-x]PKGBUILD21
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa64bd7aa94f..232ca733203b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hexchat-theme-manager
pkgdesc = A simple application to manage HexChat themes
- pkgver = 2.12.1
+ pkgver = 2.12.2
pkgrel = 1
url = https://hexchat.github.io
arch = i686
@@ -9,8 +9,8 @@ pkgbase = hexchat-theme-manager
makedepends = monodevelop
depends = mono
depends = hexchat
- source = https://dl.hexchat.net/hexchat/hexchat-2.12.1.tar.xz
- sha256sums = 5201b0c6d17dcb8c2cb79e9c39681f8e052999ba8f7b5986d5c1e7dc68fa7c6b
+ source = https://dl.hexchat.net/hexchat/hexchat-2.12.2.tar.xz
+ sha256sums = 6dad783f37aac32a8301a12d498af7a74900f011aec4e77bb378ae9797a3ccf6
pkgname = hexchat-theme-manager
diff --git a/PKGBUILD b/PKGBUILD
index 892dfa88f394..66eedc9a722a 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: TingPing <tingping@tingping.se>
pkgname=hexchat-theme-manager
-pkgver=2.12.1
+pkgver=2.12.2
pkgrel=1
pkgdesc='A simple application to manage HexChat themes'
arch=('i686' 'x86_64')
@@ -10,13 +10,14 @@ license=('GPL')
depends=('mono' 'hexchat')
makedepends=('monodevelop')
source=("https://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz")
-sha256sums=('5201b0c6d17dcb8c2cb79e9c39681f8e052999ba8f7b5986d5c1e7dc68fa7c6b')
+sha256sums=('6dad783f37aac32a8301a12d498af7a74900f011aec4e77bb378ae9797a3ccf6')
build() {
cd "hexchat-$pkgver"
- # This builds more than necessary but oh well
- ./configure --prefix=/usr --with-theme-manager \
+ # This builds more than necessary, TODO: fix upstream
+ ./configure --prefix=/usr --with-theme-manager --disable-libnotify \
+ --disable-libproxy --disable-openssl --disable-libcanberra \
--disable-gtkfe --disable-plugin --disable-dbus --disable-nls
make
}
@@ -24,17 +25,9 @@ build() {
package() {
cd "hexchat-$pkgver"
- # TODO: Fix this upstream
-
- pushd data/misc
- make install DESTDIR="$pkgdir"
- popd
-
- pushd src/htm
make install DESTDIR="$pkgdir"
- popd
- rm -r "$pkgdir/usr/share/appdata"
- rm "$pkgdir/usr/share/applications/hexchat.desktop"
+ # Translations are always built, TODO: fix upstream
+ rm -r "$pkgdir/usr/share/locale"
}