summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTingPing2015-06-08 22:07:32 -0400
committerTingPing2015-06-08 22:07:32 -0400
commit9cc66864a8f12b39b8ebff7d9c02f63b419cae48 (patch)
treeb7e98f4c4f23b0a5cc74cf9ac0b50f29d4b59d16
downloadaur-9cc66864a8f12b39b8ebff7d9c02f63b419cae48.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD32
-rw-r--r--htm-mime.xml7
-rw-r--r--htm.desktop7
-rwxr-xr-xhtm.install13
5 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c924d9dac1b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hexchat-theme-manager
+ pkgdesc = A simple application to manage HexChat themes
+ pkgver = 2.9.5
+ pkgrel = 1
+ url = http://www.hexchat.org/
+ install = htm.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = monodevelop
+ depends = mono
+ depends = hexchat
+ source = http://dl.hexchat.net/hexchat/hexchat-2.9.5.tar.xz
+ source = htm.desktop
+ source = htm-mime.xml
+ sha256sums = 11dfd0fbfb88d8dbb38f631fab8a7dffbb179f7f7dafe316953ed6f513ac623d
+ sha256sums = 1de36ac0a1fb72cef845e555635f221e72130c4afe7e3fe1c326cc0872f61c8d
+ sha256sums = 54e4a4ed2472e2ccf34df7a2f3c8f1aca0b2b4f68687969672c9e70a1e3cbef5
+
+pkgname = hexchat-theme-manager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..02afa7575c83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: TingPing <tingping@tingping.se>
+
+pkgname=hexchat-theme-manager
+pkgver=2.9.5
+pkgrel=1
+pkgdesc="A simple application to manage HexChat themes"
+arch=('i686' 'x86_64')
+url='http://www.hexchat.org/'
+license=('GPL')
+depends=('mono' 'hexchat')
+makedepends=('monodevelop')
+optdepends=()
+options=()
+install='htm.install'
+source=("http://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz"
+ 'htm.desktop' 'htm-mime.xml')
+sha256sums=('11dfd0fbfb88d8dbb38f631fab8a7dffbb179f7f7dafe316953ed6f513ac623d'
+ '1de36ac0a1fb72cef845e555635f221e72130c4afe7e3fe1c326cc0872f61c8d'
+ '54e4a4ed2472e2ccf34df7a2f3c8f1aca0b2b4f68687969672c9e70a1e3cbef5')
+
+build() {
+ cd "$srcdir/hexchat-$pkgver/src/htm"
+ mdtool build htm-mono.csproj
+}
+
+package() {
+ cd "$srcdir/hexchat-$pkgver/src/htm"
+ install -D thememan.exe "$pkgdir/usr/bin/thememan"
+ install -D "$srcdir/htm.desktop" "$pkgdir/usr/share/applications/htm.desktop"
+ install -D "$srcdir/htm-mime.xml" "$pkgdir/usr/share/mime/packages/htm.xml"
+}
+
diff --git a/htm-mime.xml b/htm-mime.xml
new file mode 100644
index 000000000000..1201aaf34457
--- /dev/null
+++ b/htm-mime.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0"?>
+ <mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-hct">
+ <comment>HexChat theme archives</comment>
+ <glob pattern="*.hct"/>
+ </mime-type>
+ </mime-info>
diff --git a/htm.desktop b/htm.desktop
new file mode 100644
index 000000000000..7651c91f108a
--- /dev/null
+++ b/htm.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=HexChat Theme Manager
+Exec=mono /usr/bin/thememan %f
+Icon=hexchat
+Terminal=false
+Type=Application
+MimeType=application/x-hct
diff --git a/htm.install b/htm.install
new file mode 100755
index 000000000000..564381a0210a
--- /dev/null
+++ b/htm.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+