summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatrix2023-07-13 15:09:56 +0100
committerMatrix2023-07-13 15:09:56 +0100
commit418b2203534e0a789200aa08314f2279efceaf80 (patch)
tree9943256a4c201fd219596e5c4522789b567fe2f3
downloadaur-418b2203534e0a789200aa08314f2279efceaf80.tar.gz
Inital commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f25613377a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hexchat-theme-manager-git
+ pkgdesc = A simple application to manage HexChat themes
+ pkgver = 2.16.1.r33.g6155c183
+ pkgrel = 1
+ url = https://hexchat.github.io
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = monodevelop
+ makedepends = meson
+ depends = mono
+ depends = hexchat>=2.16.1
+ source = git+https://github.com/hexchat/hexchat.git
+ sha256sums = SKIP
+
+pkgname = hexchat-theme-manager-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c22e13271da4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Matrix <thysupremematrix atttt tuta dottt io>
+
+pkgname=hexchat-theme-manager-git
+_root_pkgname=hexchat
+pkgver=2.16.1.r33.g6155c183
+pkgrel=1
+pkgdesc='A simple application to manage HexChat themes'
+arch=('i686' 'x86_64')
+url='https://hexchat.github.io'
+license=('GPL')
+depends=('mono' 'hexchat>=2.16.1')
+makedepends=('monodevelop' 'meson')
+source=("git+https://github.com/hexchat/hexchat.git")
+sha256sums=('SKIP')
+
+_files=(
+ "usr/share/applications/io.github.Hexchat.ThemeManager.desktop"
+ "usr/share/mime/packages/io.github.Hexchat.ThemeManager.xml"
+ "usr/bin/thememan.exe"
+ "usr/bin/thememan"
+)
+
+pkgver() {
+ cd "${srcdir}/$_root_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}"
+ arch-meson $_root_pkgname build -Dtheme-manager=true
+ meson compile -C build
+}
+
+package() {
+ cd "${srcdir}"
+ meson install -C build --destdir "${srcdir}/full" # It also builds stuff already in hexchat package
+
+ # Only install stuff not in hexchat package
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/mime/packages"
+ install -d "${pkgdir}/usr/share/applications"
+
+ for file in "${_files[@]}"
+ do
+ echo $file
+ cp "${srcdir}/full/${file}" "${pkgdir}/${file}"
+ done
+}
+
+