summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatrix2023-08-22 10:52:32 +0100
committerMatrix2023-08-22 10:52:32 +0100
commitf5e3cc1e79e10f52b4398fb121a938da2c8346c9 (patch)
tree01a356572c3461b911be263fc21e86711914918e
parentbee2aa0015cafa1974c10be5468342306ac7dc9f (diff)
downloadaur-f5e3cc1e79e10f52b4398fb121a938da2c8346c9.tar.gz
fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--thememan2
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 308ce1f04b61..05f0bd520487 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hexchat-theme-manager-git
pkgdesc = A simple application to manage HexChat themes
pkgver = 2.16.1.r34.gcda96128
- pkgrel = 2
+ pkgrel = 3
url = https://hexchat.github.io
arch = i686
arch = x86_64
@@ -11,6 +11,8 @@ pkgbase = hexchat-theme-manager-git
depends = mono
depends = hexchat>=2.16.1
source = git+https://github.com/hexchat/hexchat.git
+ source = thememan
sha256sums = SKIP
+ sha256sums = 2ac84fb550986eacaa45d2e16644589652101ab092fd7e1571d0726605efc889
pkgname = hexchat-theme-manager-git
diff --git a/PKGBUILD b/PKGBUILD
index 95b857317779..4a25af28eed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgname=hexchat-theme-manager-git
_root_pkgname=hexchat
pkgver=2.16.1.r34.gcda96128
-pkgrel=2
+pkgrel=3
pkgdesc='A simple application to manage HexChat themes'
arch=('i686' 'x86_64')
url='https://hexchat.github.io'
license=('GPL')
depends=('mono' 'hexchat>=2.16.1')
makedepends=('meson' 'msbuild')
-source=("git+https://github.com/hexchat/hexchat.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/hexchat/hexchat.git" "thememan")
+sha256sums=('SKIP'
+ '2ac84fb550986eacaa45d2e16644589652101ab092fd7e1571d0726605efc889')
pkgver() {
cd "${srcdir}/${_root_pkgname}"
@@ -32,7 +33,7 @@ build() {
package() {
install -Dm755 "${srcdir}/${_root_pkgname}/src/htm/obj/${_platform}/Release/thememan.exe" "${pkgdir}/usr/bin/thememan.exe"
- install -Dm755 "${srcdir}/${_root_pkgname}/src/htm/thememan.in" "${pkgdir}/usr/bin/thememan"
+ install -Dm755 "${srcdir}/thememan" "${pkgdir}/usr/bin/thememan"
install -Dm644 "${srcdir}/${_root_pkgname}/data/misc/io.github.Hexchat.ThemeManager.desktop.in" "${pkgdir}/usr/share/applications/io.github.Hexchat.ThemeManager.desktop"
install -Dm644 "${srcdir}/${_root_pkgname}/data/misc/io.github.Hexchat.ThemeManager.xml" "${pkgdir}/usr/share/mime/packages/io.github.Hexchat.ThemeManager.xml"
}
diff --git a/thememan b/thememan
new file mode 100644
index 000000000000..862dc23851b8
--- /dev/null
+++ b/thememan
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec mono "/usr/bin/thememan.exe"