summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2018-02-20 21:32:39 -0500
committerKyle Keen2018-02-20 21:32:39 -0500
commit0421c6e916b61f7ba7b377be1db04e4b29e8bab6 (patch)
treeb00b6c39d4eb120eae65f85f6074637900d95c24
parentbbc97d6065c45f28dc49717cdfa4b7ed5dc472a1 (diff)
downloadaur-0421c6e916b61f7ba7b377be1db04e4b29e8bab6.tar.gz
fix gcc warnings
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d6ed5def6fa..54bf1a18a61b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Feb 21 02:32:38 UTC 2018
pkgbase = hexcurse
pkgdesc = Versatile ncurses-based hex editor.
pkgver = 1.60.0
@@ -6,9 +8,8 @@ pkgbase = hexcurse
arch = i686
arch = x86_64
license = GPL
- depends = ncurses>=5.6-7
options = !makeflags
- source = https://github.com/LonnyGomes/hexcurse/archive/v1.60.0.tar.gz
+ source = hexcurse-1.60.0.tgz::https://github.com/LonnyGomes/hexcurse/archive/v1.60.0.tar.gz
md5sums = cb24b564bea21a615a5c6a2ee30d6cad
pkgname = hexcurse
diff --git a/PKGBUILD b/PKGBUILD
index d2a7d51cf387..740776a69ae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,21 @@ arch=('i686' 'x86_64')
#url="http://directory.fsf.org/project/HexCurse/"
url="https://github.com/LonnyGomes/hexcurse"
license=('GPL')
-depends=('ncurses>=5.6-7')
options=('!makeflags')
-source=("https://github.com/LonnyGomes/hexcurse/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tgz::https://github.com/LonnyGomes/hexcurse/archive/v$pkgver.tar.gz")
#source=("http://www.sourcefiles.org/Editors/Hex/$pkgname-$pkgver.tar.gz")
#source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz")
#source=("https://github.com/LonnyGomes/hexcurse/archive/hexcurse-$pkgver.tar.gz")
md5sums=('cb24b564bea21a615a5c6a2ee30d6cad')
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # gcc does not like clever people
+ sed -i 's|buffer, 1,|NULL, 0,|' src/hexcurse.c
+ sed -i 's|char buffer\[1\];|//&|' src/hexcurse.c
+ sed -i 's|2*MAXY);|&\nbreak;|' src/acceptch.c
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"