summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-11-19 22:53:44 -0500
committerKyle Keen2015-11-19 22:53:44 -0500
commitbbc97d6065c45f28dc49717cdfa4b7ed5dc472a1 (patch)
treeb060fee5133b1d2a755f827cba4ec269df7f02f4
parent715c13f03970d777153e7bbe0e701983e4a3354e (diff)
downloadaur-bbc97d6065c45f28dc49717cdfa4b7ed5dc472a1.tar.gz
1.60.0 update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--hexcurse-alloca.patch13
3 files changed, 10 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e86c71d9681b..3d6ed5def6fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hexcurse
pkgdesc = Versatile ncurses-based hex editor.
- pkgver = 1.58
+ pkgver = 1.60.0
pkgrel = 1
url = https://github.com/LonnyGomes/hexcurse
arch = i686
@@ -8,10 +8,8 @@ pkgbase = hexcurse
license = GPL
depends = ncurses>=5.6-7
options = !makeflags
- source = https://github.com/LonnyGomes/hexcurse/archive/hexcurse-1.58.tar.gz
- source = hexcurse-alloca.patch
- md5sums = 26c3ccf56850ff030d5097ee4bbc2b0b
- md5sums = fb7723bff0411392fe410839f6105e4f
+ source = https://github.com/LonnyGomes/hexcurse/archive/v1.60.0.tar.gz
+ md5sums = cb24b564bea21a615a5c6a2ee30d6cad
pkgname = hexcurse
diff --git a/PKGBUILD b/PKGBUILD
index 82f475a47739..d2a7d51cf387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: eric <eric@archlinux.org>
pkgname=hexcurse
-pkgver=1.58
+pkgver=1.60.0
pkgrel=1
pkgdesc="Versatile ncurses-based hex editor."
arch=('i686' 'x86_64')
@@ -11,17 +11,14 @@ url="https://github.com/LonnyGomes/hexcurse"
license=('GPL')
depends=('ncurses>=5.6-7')
options=('!makeflags')
-source=("https://github.com/LonnyGomes/hexcurse/archive/hexcurse-$pkgver.tar.gz"
- "hexcurse-alloca.patch")
+source=("https://github.com/LonnyGomes/hexcurse/archive/v$pkgver.tar.gz")
#source=("http://www.sourcefiles.org/Editors/Hex/$pkgname-$pkgver.tar.gz")
-#source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz"
-md5sums=('26c3ccf56850ff030d5097ee4bbc2b0b'
- 'fb7723bff0411392fe410839f6105e4f')
+#source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz")
+#source=("https://github.com/LonnyGomes/hexcurse/archive/hexcurse-$pkgver.tar.gz")
+md5sums=('cb24b564bea21a615a5c6a2ee30d6cad')
build() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
-
- #patch -p0 < ../hexcurse-alloca.patch
+ cd "$srcdir/$pkgname-$pkgver"
./configure \
--prefix=/usr \
@@ -31,7 +28,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
diff --git a/hexcurse-alloca.patch b/hexcurse-alloca.patch
deleted file mode 100644
index e12e8737fe73..000000000000
--- a/hexcurse-alloca.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/getopt.c 2002-03-21 17:55:54.000000000 +0100
-+++ /root/getopt.c 2004-08-09 12:52:39.592951560 +0200
-@@ -36,8 +36,8 @@
- * enables hexcurse to be compiled with SGI's proprietary compiler */
- #ifdef _SGIAPI
- #include <alloca.h>
--#else
--char *alloca ();
-+//#else
-+//char *alloca ();
- #endif
- #define __alloca alloca
- /* end of modification */