summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2022-12-01 22:45:44 +0100
committerDanilo Bargen2022-12-01 22:45:44 +0100
commit06bfba0ef718310c53877f2d456ac58745faef84 (patch)
tree33fe2c53dcc4d484a2c8e5fcea499a8c82a5a550
parent25813cb3932a5261d67cc0ac51c6b2c3e6c394fd (diff)
downloadaur-06bfba0ef718310c53877f2d456ac58745faef84.tar.gz
Version r155.6397896-1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36465b56d470..da348b5e7b52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Oct 22 15:15:07 UTC 2018
pkgbase = hexdino-git
pkgdesc = A hex editor with vim like keybindings written in Rust.
- pkgver = r66.b134144
+ pkgver = r155.6397896
pkgrel = 1
url = https://github.com/Luz/hexdino
arch = x86_64
@@ -14,10 +12,8 @@ pkgbase = hexdino-git
provides = hexdino
conflicts = hexdino
options = !emptydirs
+ options = !strip
source = git+https://github.com/Luz/hexdino
md5sums = SKIP
- depends_x86_64 = ncurses
- depends_i686 = lib32-ncurses
pkgname = hexdino-git
-
diff --git a/.gitignore b/.gitignore
index ab1174f0fcb3..70434a8358b6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ src/
pkg/
*.swp
*.tar.xz
+*.tar.zst
hexdino/
diff --git a/PKGBUILD b/PKGBUILD
index 84c1462a09b3..00e1099de39e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
pkgname=hexdino-git
_name=hexdino
-pkgver=r66.b134144
-pkgrel=2
+pkgver=r155.6397896
+pkgrel=1
pkgdesc="A hex editor with vim like keybindings written in Rust."
arch=('x86_64' 'i686')
url="https://github.com/Luz/hexdino"
license=('MIT')
-depends_i686=('lib32-ncurses')
-depends_x86_64=('ncurses')
+depends=()
makedepends=('git' 'rust' 'cargo')
provides=('hexdino')
conflicts=('hexdino')
@@ -23,8 +22,8 @@ build() {
package() {
cd "$srcdir/$_name"
- mkdir -p $pkgdir/usr/bin
- install -o root -g root -m 755 target/release/hexdino $pkgdir/usr/bin
+ mkdir -p "$pkgdir/usr/bin"
+ install -o root -g root -m 755 target/release/hexdino "$pkgdir/usr/bin"
}
pkgver() {