summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2016-03-07 21:27:24 +0100
committerDanilo Bargen2016-03-07 21:27:24 +0100
commitd11897098f9b9ffc9b7897b82416a66ed93f8193 (patch)
tree0a708a4be558bff4782c07800ac04c07a304d037
downloadaur-d11897098f9b9ffc9b7897b82416a66ed93f8193.tar.gz
Version r13.b5ba540-1
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29fdbcd560da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Mar 7 20:26:27 UTC 2016
+pkgbase = hexdino-git
+ pkgdesc = A hex editor with vim like keybindings written in Rust.
+ pkgver = r13.b5ba540
+ pkgrel = 1
+ url = https://github.com/Luz/hexdino
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ provides = hexdino
+ conflicts = hexdino
+ options = !emptydirs
+ source = git+https://github.com/Luz/hexdino
+ md5sums = SKIP
+ depends_x86_64 = ncurses
+ depends_i686 = lib32-ncurses
+
+pkgname = hexdino-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ab1174f0fcb3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.swp
+*.tar.xz
+hexdino/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89ae4256c406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+pkgname=hexdino-git
+_name=hexdino
+pkgver=r13.b5ba540
+pkgrel=1
+pkgdesc="A hex editor with vim like keybindings written in Rust."
+arch=('x86_64' 'i686')
+url="https://github.com/Luz/hexdino"
+license=('MIT')
+depends_i686=('lib32-ncurses')
+depends_x86_64=('ncurses')
+makedepends=('git' 'rust' 'cargo')
+provides=('hexdino')
+conflicts=('hexdino')
+options=(!emptydirs)
+source=('git+https://github.com/Luz/hexdino')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_name"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$_name"
+ mkdir -p $pkgdir/usr/bin
+ install -o root -g root -m 755 target/release/hexdino $pkgdir/usr/bin
+}
+
+pkgver() {
+ cd "$srcdir/$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# vim:set ts=2 sw=2 et: