summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuinn2024-02-14 06:06:38 +0000
committerQuinn2024-02-14 06:06:38 +0000
commit909fed0eddf853f3bffc6b214e363c6d3456d261 (patch)
treeffe356a74f3c7e1afc9f8b6dbc9e7254ed4fc0e6
downloadaur-909fed0eddf853f3bffc6b214e363c6d3456d261.tar.gz
0.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef4183150c89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hexfetch
+ pkgdesc = a simple and fast program that gets simple system information.
+ pkgver = 0.1.r26.cd014e3
+ pkgrel = 1
+ url = https://github.com/hexisXz/hexfetch.git
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = make
+ depends = lsb-release
+ depends = figlet
+ source = git+https://github.com/hexisXz/hexfetch.git
+ sha256sums = SKIP
+
+pkgname = hexfetch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bc20654dd04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Your Name Quinn/wolfgang/hexis (qk371994@gmail.com)
+pkgname=hexfetch
+pkgver=0.1.r26.cd014e3
+pkgrel=1
+epoch=
+pkgdesc="a simple and fast program that gets simple system information."
+arch=(x86_64)
+url="https://github.com/hexisXz/hexfetch.git"
+license=('MIT')
+groups=()
+depends=(lsb-release figlet)
+makedepends=(git make)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+sha256sums=(SKIP)
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "0.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$pkgname"
+ gcc $pkgname.c -o $pkgname && sudo mv $pkgname /bin/
+
+}