summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Petrescu2017-08-31 11:38:11 -0400
committerAdrian Petrescu2017-08-31 11:38:11 -0400
commitf430b4afb44707e8fc3fa3c8a166925e4d9db6f9 (patch)
tree8b44f0628b619ba5de8c6ab59eae2071ea2dcd05
downloadaur-f430b4afb44707e8fc3fa3c8a166925e4d9db6f9.tar.gz
First commit of hexgui v0.9.1
Works as far as I can tell.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rwxr-xr-xhexgui2
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a379bda38855
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hexgui
+ pkgdesc = SGF editor and engine client for the board game Hex
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = http://sourceforge.net/p/benzene/hexgui
+ arch = any
+ license = GPL3
+ makedepends = apache-ant
+ makedepends = java-environment
+ depends = bash
+ depends = java-runtime
+ source = https://github.com/apetresc/hexgui/archive/v0.9.1.tar.gz
+ source = hexgui
+ md5sums = eb264a51b3b446d79ef1628a4bbf6e2a
+ md5sums = 77035cf26c8a2e4c656ad874b44ccf29
+
+pkgname = hexgui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99c1d258eb4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Adrian Petrescu <apetresc@gmail.com>
+# Maintainer: Adrian Petrescu <apetresc@gmail.com>
+
+pkgname=hexgui
+pkgver=0.9.1
+pkgrel=1
+pkgdesc='SGF editor and engine client for the board game Hex'
+arch=('any')
+url='http://sourceforge.net/p/benzene/hexgui'
+license=('GPL3')
+depends=('bash' 'java-runtime')
+makedepends=('apache-ant' 'java-environment')
+source=("https://github.com/apetresc/hexgui/archive/v$pkgver.tar.gz" 'hexgui')
+md5sums=('eb264a51b3b446d79ef1628a4bbf6e2a'
+ '77035cf26c8a2e4c656ad874b44ccf29')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ant
+}
+
+check() {
+ cd $pkgname-$pkgver
+ bin/hexgui -version
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/java/hexgui
+ mkdir -p $pkgdir/usr/bin
+
+ cp $srcdir/$pkgname-$pkgver/lib/hexgui.jar $pkgdir/usr/share/java/hexgui/hexgui.jar
+ cp hexgui $pkgdir/usr/bin/hexgui
+}
+
diff --git a/hexgui b/hexgui
new file mode 100755
index 000000000000..6f47c0da202c
--- /dev/null
+++ b/hexgui
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/java -jar '/usr/share/java/hexgui/hexgui.jar' "$@"