summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorliolok2021-06-19 19:55:45 +0800
committerliolok2021-06-19 19:55:45 +0800
commit5368a779ae2a440c4d0223ad2f100e5deaa3ccca (patch)
tree9df01774a4e8ab8ceaaacdc037aafaf18fef54f5
parent79da2b75316fa777416cdd4a3c602e05708a4b92 (diff)
downloadaur-5368a779ae2a440c4d0223ad2f100e5deaa3ccca.tar.gz
change pkgname
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19b523d6f962..020345676a35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
+# Maintainer: liolok <aur@liolok.com>
# Maintainer: Mike Yuan <me@yhndnzj.com>
-pkgname=nodejs-hexo-cli
-_pkgname=${pkgname#nodejs-}
+pkgname=hexo-cli
pkgver=4.2.0
pkgrel=2
pkgdesc="Command line interface for Hexo"
arch=('any')
-url="https://www.npmjs.com/package/$_pkgname"
+url="https://www.npmjs.com/package/$pkgname"
license=('MIT')
depends=('nodejs')
makedepends=('npm')
conflicts=('nodejs-hexo')
-source=(https://registry.npmjs.org/$_pkgname/-/$_pkgname-$pkgver.tgz)
-noextract=($_pkgname-$pkgver.tgz)
+source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
sha256sums=('f169b782712f88eb4ebfc7498a359a0535852c2166e7f58193b85caee8f992e9')
package() {
- npm install -g --prefix "$pkgdir/usr" "$srcdir/$_pkgname-$pkgver.tgz"
+ npm install --global --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
# Non-deterministic race in npm gives 777 permissions to random directories.
# See https://github.com/npm/cli/issues/1103 for details.