summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorsMortium2023-06-18 11:37:24 +0200
committerMorsMortium2023-06-18 11:37:24 +0200
commit198302225df86b28964054914f1776dfbaef2470 (patch)
treea7ddb37a1869f4850bea7da80aa54d68d18e4117
parent62f430f595aba5ecb6cd60f1bc9b78676475d907 (diff)
downloadaur-198302225df86b28964054914f1776dfbaef2470.tar.gz
Correct packaging
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b6bb849473c..fe1e41dd2a15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,12 @@ pkgbase = hexon-git
pkgrel = 1
url = https://gitlab.com/luckeyproductions/games/hexon
arch = any
- license = GPL-2.0
+ license = GPL2
makedepends = git
- makedepends = gcc
- makedepends = make
makedepends = qt5-base
depends = dry
provides = hexon
+ conflicts = hexon
source = hexon-git::git+https://gitlab.com/luckeyproductions/games/hexon.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e574e78b088c..4a7f8fefc2e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,17 @@ pkgrel=1
pkgdesc='heXon is a free and open source twin-stick-shooter created using the Dry game engine.'
arch=('any')
url="https://gitlab.com/luckeyproductions/games/${_pkgname}"
-license=('GPL-2.0')
+license=('GPL2')
depends=('dry')
provides=("${_pkgname}")
-makedepends=('git' 'gcc' 'make' 'qt5-base')
+conflicts=("${_pkgname}")
+makedepends=('git' 'qt5-base')
sha512sums=('SKIP')
source=("${pkgname}::git+${url}.git")
pkgver() {
cd "${srcdir}/${pkgname}"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {