summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorsMortium2023-06-18 10:15:26 +0200
committerMorsMortium2023-06-18 10:15:26 +0200
commit62f430f595aba5ecb6cd60f1bc9b78676475d907 (patch)
tree0cf7aeb42b436440d65780d1154c5410532626f2
downloadaur-62f430f595aba5ecb6cd60f1bc9b78676475d907.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b6bb849473c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hexon-git
+ pkgdesc = heXon is a free and open source twin-stick-shooter created using the Dry game engine.
+ pkgver = 491.f160b5f
+ pkgrel = 1
+ url = https://gitlab.com/luckeyproductions/games/hexon
+ arch = any
+ license = GPL-2.0
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ makedepends = qt5-base
+ depends = dry
+ provides = hexon
+ source = hexon-git::git+https://gitlab.com/luckeyproductions/games/hexon.git
+ sha512sums = SKIP
+
+pkgname = hexon-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e574e78b088c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer : MorsMortium <morsmortium@disroot.org>
+
+_pkgname=hexon
+pkgname=${_pkgname}-git
+pkgver=491.f160b5f
+pkgrel=1
+pkgdesc='heXon is a free and open source twin-stick-shooter created using the Dry game engine.'
+arch=('any')
+url="https://gitlab.com/luckeyproductions/games/${_pkgname}"
+license=('GPL-2.0')
+depends=('dry')
+provides=("${_pkgname}")
+makedepends=('git' 'gcc' 'make' 'qt5-base')
+sha512sums=('SKIP')
+source=("${pkgname}::git+${url}.git")
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ rm -f Dry
+ ln -s /opt/dry/ Dry
+ qmake heXon.pro "DATADIR=/usr/share"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm 644 hexon.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/hexon.svg
+ install -Dm 755 hexon ${pkgdir}/usr/bin/hexon
+ install -Dm 755 hexon.desktop ${pkgdir}/usr/share/applications/hexon.desktop
+ mkdir -p ${pkgdir}/usr/share/luckey/hexon
+ cp -R "${srcdir}/${pkgname}/Resources/." ${pkgdir}/usr/share/luckey/hexon/
+}