summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-05-16 23:33:39 +0200
committerMichal Wojdyla2024-05-16 23:33:39 +0200
commitdc2aded27ed57acd9be42279f9e28fcbef485e86 (patch)
tree9d9a8359bb8753714df2ef0c2644e9840266e9db
parented7f15e616a130da116f801aa8aa56f900990b62 (diff)
downloadaur-dc2aded27ed57acd9be42279f9e28fcbef485e86.tar.gz
fix build with gcc14 for xhfs, move optdepends to depends
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD14
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38523ca17d7c..5835c7f08609 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = hfsutils
pkgdesc = HFS Access utils
pkgver = 3.2.6_p16
- pkgrel = 1
+ pkgrel = 2
url = https://www.mars.org/home/rob/proj/hfs/
arch = x86_64
license = GPL2
depends = glibc
- optdepends = tcl: xhfs GUI
- optdepends = tk: xhfs GUI
+ depends = tcl
+ depends = tk
source = https://deb.debian.org/debian/pool/main/h/hfsutils/hfsutils_3.2.6.orig.tar.gz
source = https://deb.debian.org/debian/pool/main/h/hfsutils/hfsutils_3.2.6-16.debian.tar.xz
sha256sums = bc9d22d6d252b920ec9cdf18e00b7655a6189b3f34f42e58d5bb152957289840
diff --git a/PKGBUILD b/PKGBUILD
index 862bc6e49f35..60ece8cfced6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,12 @@
# Contributor: Pablo Lezaeta <prflr88@gmail.com>
pkgname=hfsutils
pkgver=3.2.6_p16
-pkgrel=1
+pkgrel=2
pkgdesc="HFS Access utils"
arch=('x86_64')
license=('GPL2')
url="https://www.mars.org/home/rob/proj/hfs/"
-depends=(glibc)
-optdepends=('tcl: xhfs GUI'
- 'tk: xhfs GUI')
+depends=(glibc tcl tk)
source=(
"https://deb.debian.org/debian/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver/_p*}.orig.tar.gz"
"https://deb.debian.org/debian/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver/_p/-}.debian.tar.xz"
@@ -28,12 +26,8 @@ prepare() {
build() {
cd "${pkgname}-${pkgver%_p*}"
autoreconf -fi
- # test for tcl and tk presence
- if [ -x /usr/bin/tclsh -a -x /usr/bin/wish ]; then
- ./configure --with-tcl --with-tk
- else
- ./configure
- fi
+ CFLAGS="$CFLAGS -Wno-error=incompatible-pointer-types"
+ ./configure --with-tcl --with-tk
make prefix=/usr
make -C hfsck prefix=/usr
}