summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2024-03-19 17:03:36 +0000
committerSpyros Stathopoulos2024-03-19 17:03:36 +0000
commit1a4988ef7cd768428bac5329b165e51bd3616123 (patch)
tree748225fb09c7da7ea03cd99e47ac7fafb1da6b8d
parent0565a371033a26f3c90c565f241a09e8e50a6026 (diff)
downloadaur-hg-git-hg.tar.gz
Update packaging standards
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f64df45c7bab..bc39fe29e056 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = hg-git-hg
pkgdesc = the Hg-Git mercurial plugin
- pkgver = 1860.d6672f726bcf
+ pkgver = 1951.e799e4fad448
pkgrel = 1
url = http://hg-git.github.io/
arch = any
license = GPL2
makedepends = mercurial
makedepends = python-setuptools-scm
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = mercurial
depends = python-dulwich
provides = hg-git
diff --git a/PKGBUILD b/PKGBUILD
index dc8ceab14be1..f39cdf93f8ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
# Contributor: Egor Kuropatkin <egor.k8n@gmail.com>
# Contributor: Egor Laufer <egor.l4r@gmail.com>
#
-name=hg-git
-pkgname=$name-hg
-pkgver=1860.d6672f726bcf
+_name=hg-git
+pkgname=$_name-hg
+pkgver=1951.e799e4fad448
pkgrel=1
pkgdesc="the Hg-Git mercurial plugin"
arch=(any)
url="http://hg-git.github.io/"
license=('GPL2')
depends=('mercurial' 'python-dulwich')
-makedepends=('mercurial' 'python-setuptools-scm')
+makedepends=('mercurial' 'python-setuptools-scm'
+ 'python-build' 'python-installer'
+ 'python-wheel')
provides=('hg-git')
conflicts=('hg-git')
source=('hg+https://foss.heptapod.net/mercurial/hg-git'
@@ -20,12 +22,17 @@ md5sums=('SKIP'
'592a454e09f498074c57a5b7e383e808')
pkgver() {
- cd "$srcdir/$name"
+ cd "$srcdir/$_name"
hg identify -ni | awk 'BEGIN{OFS=".";} {print $2,$1}'
}
+build() {
+ cd "$srcdir/$_name"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd $srcdir/$name
- python setup.py install --prefix=/usr --root=$pkgdir
+ cd $srcdir/$_name
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -m0644 -D "${srcdir}/hggit.rc" "${pkgdir}/etc/mercurial/hgrc.d/hggit.rc"
}