summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEgor Laufer2015-07-20 00:14:14 +0300
committerEgor Laufer2015-07-20 00:16:09 +0300
commit45efea7b4ef66bf96b20f3c25f4e059eff133521 (patch)
treed9d7bba1ffd85d6654dc4651d7f95ee8d58733ca
downloadaur-45efea7b4ef66bf96b20f3c25f4e059eff133521.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
-rw-r--r--hggit.rc2
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c77c508923f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hg-git-hg
+ pkgdesc = the Hg-Git mercurial plugin
+ pkgver = 631.711baa274f78
+ pkgrel = 1
+ url = http://hg-git.github.com/
+ arch = any
+ license = GPL2
+ makedepends = mercurial
+ depends = mercurial
+ depends = python2-dulwich
+ provides = hg-git
+ conflicts = hg-git
+ source = hg+https://bitbucket.org/durin42/hg-git
+ source = hggit.rc
+ md5sums = SKIP
+ md5sums = 592a454e09f498074c57a5b7e383e808
+
+pkgname = hg-git-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48b1bd2b4333
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# -*- shell-script -*-
+# Arch Linux package build script
+#
+# Contributor: Vsevolod Balashov <vsevolod@balashov.name>
+# Contributor: Egor Kuropatkin <egor.k8n@gmail.com>
+# Contributor: Egor Laufer <egor.l4r@gmail.com>
+#
+name=hg-git
+pkgname=$name-hg
+pkgver=631.711baa274f78
+pkgrel=1
+pkgdesc="the Hg-Git mercurial plugin"
+arch=(any)
+url="http://hg-git.github.com/"
+license=('GPL2')
+depends=('mercurial' 'python2-dulwich')
+makedepends=('mercurial')
+provides=('hg-git')
+conflicts=('hg-git')
+source=('hg+https://bitbucket.org/durin42/hg-git'
+ 'hggit.rc')
+md5sums=('SKIP'
+ '592a454e09f498074c57a5b7e383e808')
+
+pkgver() {
+ cd "$srcdir/$name"
+ hg identify -ni | awk 'BEGIN{OFS=".";} {print $2,$1}'
+}
+
+package() {
+ cd $srcdir/$name
+ python2 setup.py install --prefix=/usr --root=$pkgdir
+ install -m0644 -D "${srcdir}/hggit.rc" "${pkgdir}/etc/mercurial/hgrc.d/hggit.rc"
+}
+
+# Changelog
+################################################################################
+# * Sun Jul 19 2015 Egor Laufer <egor.l4r@gmail.com>
+# - Moved package to aur4
+#
+# * Fri Nov 29 2013 Egor Kuropatkin <egor.k8n@gmail.com>
+# - Replaced python-dulwich dependency with python2-dulwich
+#
+# * Thu Aug 08 2013 Egor Kuropatkin <egor.k8n@gmail.com>
+# - Add pkgver function.
+# - Add hggit.rc: this file will be placed to /etc/merucrial/hgrc.d/ to enable
+# hggit extention by default.
+# - Remove .install file
diff --git a/hggit.rc b/hggit.rc
new file mode 100644
index 000000000000..299851aeb92d
--- /dev/null
+++ b/hggit.rc
@@ -0,0 +1,2 @@
+[extensions]
+hggit =