summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Gagarski2015-06-09 18:56:49 +0300
committerKirill Gagarski2015-06-09 18:56:49 +0300
commit5e89f627e82172f6015baff5cad77efb942beade (patch)
treee752d769265fd527f70a935cef8b256d8a8882b6
downloadaur-hgtui-hg.tar.gz
Intitial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b10f980b6c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hgtui-hg
+ pkgdesc = Textual user interface frontend for DSCM mercurial
+ pkgver = 378
+ pkgrel = 2
+ url = http://code.google.com/p/hgtui/
+ arch = any
+ license = GPL
+ makedepends = mercurial
+ makedepends = gettext
+ depends = python2
+ depends = python2-lxml
+ depends = mercurial
+ depends = ncurses
+ provides = hgtui
+ conflicts = hgtui
+ source = hg+https://bitbucket.org/hgtui/hgtui
+ md5sums = SKIP
+
+pkgname = hgtui-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b91d4dc45c95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#Maintainer: Maxim Petrov <maximpetrov [at] yahoo.com>
+pkgname=hgtui-hg
+
+_hgrepo="hgtui"
+source=("hg+https://bitbucket.org/hgtui/$_hgrepo")
+
+pkgver=378
+pkgrel=2
+pkgdesc="Textual user interface frontend for DSCM mercurial"
+arch=('any')
+url="http://code.google.com/p/hgtui/"
+license=('GPL')
+makedepends=('mercurial' 'gettext')
+depends=('python2' 'python2-lxml' 'mercurial' 'ncurses')
+provides=('hgtui')
+conflicts=('hgtui')
+install=
+
+md5sums=("SKIP")
+
+package() {
+ cd "$srcdir/$_hgrepo"
+ python2 setup.py install --root="${pkgdir}/"
+ make -C po build
+ DESTDIR=${pkgdir} make -C po install
+ make -C po clean
+}
+
+pkgver() {
+ cd "$srcdir/$_hgrepo"
+ hg identify -n
+}