summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 16:19:51 +0200
committerChristian Hesse2015-06-30 16:19:51 +0200
commitae11639c192fa069b46999fc112f0ddbcde71684 (patch)
tree6ee445923c547a600697119e729998bb0ba30a04
downloadaur-ae11639c192fa069b46999fc112f0ddbcde71684.tar.gz
initial import of hgweb 3.4.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--hgweb.conf2
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c121ebe0cfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hgweb
+ pkgdesc = Mercurial web interface
+ pkgver = 3.4.1
+ pkgrel = 1
+ url = http://mercurial.selenic.com/
+ arch = any
+ license = GPL
+ depends = mercurial
+ depends = python2
+ backup = etc/conf.d/hgweb.conf
+ source = http://mercurial.selenic.com/release/mercurial-3.4.1.tar.gz
+ source = hgweb.conf
+ sha256sums = 7a8acf7329beda38ceea29c689212574d9a6bfffe24cf565015ea0066f7cee3f
+ sha256sums = ceccc16a49d074f4981297041f0f526c04838cd8541ecc891d87513f8a8ba62f
+
+pkgname = hgweb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3672c7f2c042
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=hgweb
+pkgver=3.4.1
+pkgrel=1
+pkgdesc='Mercurial web interface'
+arch=('any')
+url='http://mercurial.selenic.com/'
+license=('GPL')
+depends=('mercurial' 'python2')
+source=("http://mercurial.selenic.com/release/mercurial-${pkgver}.tar.gz"
+ 'hgweb.conf')
+backup=('etc/conf.d/hgweb.conf')
+sha256sums=('7a8acf7329beda38ceea29c689212574d9a6bfffe24cf565015ea0066f7cee3f'
+ 'ceccc16a49d074f4981297041f0f526c04838cd8541ecc891d87513f8a8ba62f')
+
+build() {
+ sed -i -e '/#!/s|python|python2|' -e '/^config/c config = "/etc/conf.d/hgweb.conf"' ${srcdir}/mercurial-${pkgver}/hgweb.cgi
+}
+
+package() {
+ install -D -m0755 ${srcdir}/mercurial-${pkgver}/hgweb.cgi ${pkgdir}/srv/http/hg/hgweb.cgi
+ install -D -m0644 ${srcdir}/hgweb.conf ${pkgdir}/etc/conf.d/hgweb.conf
+}
+
diff --git a/hgweb.conf b/hgweb.conf
new file mode 100644
index 000000000000..eb09b4e4b3fc
--- /dev/null
+++ b/hgweb.conf
@@ -0,0 +1,2 @@
+[paths]
+/ = /srv/hg/*