summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquín Ignacio Aramendía2022-12-22 20:03:41 -0300
committerJoaquín Ignacio Aramendía2022-12-22 20:03:41 -0300
commite5be833a1a29b2b263131f62aa6495d0f77310ef (patch)
tree292da1cd3e0043b43dfcdba485f7e65994291ddc
parentfcc9ed0d5ed8ccb728ac123b5a902e2dd9b11202 (diff)
downloadaur-e5be833a1a29b2b263131f62aa6495d0f77310ef.tar.gz
Improve PKGBUILD quality a little
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87430913e9f7..ddbc9fb3a5cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,13 +5,12 @@ pkgbase = hhfc-git
url = https://github.com/Samsagax/hhfc
arch = any
license = GPL3
- makedepends = python-yaml
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
makedepends = git
- depends = python-pyyaml
+ depends = python-yaml
provides = hhfc
conflicts = hhfc
source = hhfc::git+https://github.com/Samsagax/hhfc.git
diff --git a/PKGBUILD b/PKGBUILD
index d34a140c8c58..e66bca502f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,12 @@ pkgdesc="Hwmon Handheld Fan Controller (hhfc) is a user space driver for fans ba
arch=('any')
url="https://github.com/Samsagax/hhfc"
license=('GPL3')
-depends=('python-pyyaml')
-makedepends=('python-yaml'
- 'python-build'
- 'python-installer'
- 'python-wheel'
- 'python-setuptools'
- 'git')
+depends=('python-yaml')
+makedepends=('python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools'
+ 'git')
provides=("hhfc")
conflicts=("hhfc")
source=("${_pkgbase}::git+https://github.com/Samsagax/hhfc.git")
@@ -25,10 +24,6 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/${_pkgbase}"
-}
-
build() {
cd "$srcdir/${_pkgbase}"
python -m build --wheel --no-isolation