summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Seemayer2015-07-06 10:11:37 +0200
committerStefan Seemayer2015-07-06 10:11:37 +0200
commit9e70366ac9aea0fb714cb392276029aec748303a (patch)
tree2eac0d47fc3885bc61d059471cde4eba61f6a408
downloadaur-9e70366ac9aea0fb714cb392276029aec748303a.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--hhsuite.sh2
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a174537955e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hhsuite
+ pkgdesc = A set of programs for protein sequence homology detection by iterative HMM-HMM comparison for computational biology like PSI-BLAST
+ pkgver = 2.0.16
+ pkgrel = 2
+ url = http://hhblits.genzentrum.lmu.de/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpng
+ source = ftp://toolkit.lmb.uni-muenchen.de/pub/HH-suite/releases/hhsuite-2.0.16.tar.gz
+ source = hhsuite.sh
+ md5sums = 39f9c6ed31e49618e7868a5b81f9ddef
+ md5sums = fe3864b3095fa7243b67dcee0f95ba38
+
+pkgname = hhsuite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28e4fb3178c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stefan Seemayer <seemayer@genzentrum.lmu.de>
+# Author: Andy Hauser <hauser@genzentrum.lmu.de>
+
+pkgname=hhsuite
+pkgver=2.0.16
+pkgrel=2
+pkgdesc="A set of programs for protein sequence homology detection by iterative HMM-HMM comparison for computational biology like PSI-BLAST"
+arch=('i686' 'x86_64')
+url="http://hhblits.genzentrum.lmu.de/"
+license=(GPL)
+depends=('libpng')
+
+source=("ftp://toolkit.lmb.uni-muenchen.de/pub/HH-suite/releases/$pkgname-$pkgver.tar.gz"
+ "hhsuite.sh")
+md5sums=('39f9c6ed31e49618e7868a5b81f9ddef'
+ 'fe3864b3095fa7243b67dcee0f95ba38')
+
+build()
+{
+ cd $srcdir/$pkgname-$pkgver/
+ make all WITH_NATIVE=1 NO_PNG=1
+}
+
+package()
+{
+ cd $srcdir/$pkgname-$pkgver/
+ make install INSTALL_DIR="${pkgdir}/usr"
+ install -Dm755 "$srcdir/hhsuite.sh" "${pkgdir}/etc/profile.d/hhsuite.sh"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/hhsuite.sh b/hhsuite.sh
new file mode 100644
index 000000000000..f638132279a3
--- /dev/null
+++ b/hhsuite.sh
@@ -0,0 +1,2 @@
+export HHLIB=/usr/lib/hh
+export PERLLIB=$PERLLIB:/usr/lib/hh/scripts