summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-08-19 05:52:05 +0800
committerYen Chi Hsuan2015-08-19 05:52:05 +0800
commit2f0b7eaf941721726815e97d95a6f528afe29772 (patch)
treeb8d87a71a2f7ce6022eb396455acee8701f89330
parent72c77c3b2cdb3cdf0ec0232a634f0d927f56c9fc (diff)
downloadaur-2f0b7eaf941721726815e97d95a6f528afe29772.tar.gz
Use local patched php.ini to avoid warnings in check()
Also, passed clean chroot build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--php_ini.patch37
3 files changed, 50 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2f1aa8abcea..24e7b5f5c864 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hhvm-git
pkgdesc = Virtual Machine, Runtime, and JIT for PHP
- pkgver = 20150813
+ pkgver = 20150816
pkgrel = 1
url = http://hhvm.com
install = hhvm.install
@@ -11,7 +11,7 @@ pkgbase = hhvm-git
makedepends = clang
makedepends = boost
makedepends = python2
- makedepends = pfff-git
+ makedepends = pfff
makedepends = ocaml-findlib
makedepends = gperf
depends = boost-libs
@@ -47,7 +47,7 @@ pkgbase = hhvm-git
source = hhvm@.service
source = server.ini
source = systemd-server.conf
- source = cache-is-executable-result.patch
+ source = php_ini.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -61,7 +61,7 @@ pkgbase = hhvm-git
sha256sums = dddf4325926a41b3f1b5a41a1a42364ee463ab627f9d9b05ccf7c4660af3a51c
sha256sums = bca85e0445f3e26df65876c52e507aec8146cd31cce12c82846b55705529caed
sha256sums = 66ae41fb6ef07dd02a9c959ab6b6e07bcb1d17b0c164a091fc5ecd9dc7967cd0
- sha256sums = 1a255f99387f4fbf8c337bc44683a330cce2b1930fa150669932f7d14f2dccab
+ sha256sums = f878bca477ce33d43a0a110a961b1b9aa600cf7000df756d1fe25f8dcde87da8
pkgname = hhvm-git
diff --git a/PKGBUILD b/PKGBUILD
index cd43ae05097d..4339c4885238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=hhvm
_github_addr=facebook/hhvm
pkgname=${_pkgname}-git
-pkgver=20150813
+pkgver=20150816
pkgrel=1
pkgdesc="Virtual Machine, Runtime, and JIT for PHP"
arch=('x86_64')
@@ -33,7 +33,7 @@ depends=('boost-libs'
# gd is bundled in hphp/runtime/ext/gd/libgd
# libxml2 included in libxslt
# pcre included in lots of packages
-makedepends=('git' 'cmake' 'clang' 'boost' 'python2' 'pfff-git' 'ocaml-findlib' 'gperf')
+makedepends=('git' 'cmake' 'clang' 'boost' 'python2' 'pfff' 'ocaml-findlib' 'gperf')
source=("git+https://github.com/$_github_addr" #1
"git+https://github.com/hhvm/hhvm-third-party"
"git+https://github.com/facebook/folly"
@@ -47,7 +47,7 @@ source=("git+https://github.com/$_github_addr" #1
'hhvm@.service'
'server.ini'
'systemd-server.conf'
- 'cache-is-executable-result.patch')
+ 'php_ini.patch')
backup=('etc/hhvm/server.ini' 'etc/hhvm/systemd-server.conf')
sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP'
@@ -55,7 +55,7 @@ sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'dddf4325926a41b3f1b5a41a1a42364ee463ab627f9d9b05ccf7c4660af3a51c'
'bca85e0445f3e26df65876c52e507aec8146cd31cce12c82846b55705529caed'
'66ae41fb6ef07dd02a9c959ab6b6e07bcb1d17b0c164a091fc5ecd9dc7967cd0'
- '1a255f99387f4fbf8c337bc44683a330cce2b1930fa150669932f7d14f2dccab')
+ 'f878bca477ce33d43a0a110a961b1b9aa600cf7000df756d1fe25f8dcde87da8')
install=hhvm.install
@@ -68,7 +68,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- patch -p1 -i ../cache-is-executable-result.patch
git submodule init
git config submodule.third-party.url "${srcdir}/hhvm-third-party"
@@ -127,10 +126,12 @@ build() {
}
check() {
- msg2 "Make sure to enable posix.so and sysvmsg.so in php.ini for correct testing"
+ cd "${srcdir}"
+ cp /etc/php/php.ini php_patched.ini
+ patch -p1 -i php_ini.patch
- cd "${srcdir}/${_pkgname}/hphp/test"
- ./run --threads 2 quick
+ cd "${srcdir}/${_pkgname}/hphp/test"
+ php -c "${srcdir}/php_patched.ini" ./run --threads 2 quick
# ./run --threads 2 all
}
diff --git a/php_ini.patch b/php_ini.patch
new file mode 100644
index 000000000000..df087e90f29f
--- /dev/null
+++ b/php_ini.patch
@@ -0,0 +1,37 @@
+--- a/php.ini 2015-08-07 01:24:13.000000000 +0800
++++ b/php_patched.ini 2015-08-19 02:13:40.040393690 +0800
+@@ -295,7 +295,7 @@
+ ; and below. This directive makes most sense if used in a per-directory
+ ; or per-virtualhost web server configuration file.
+ ; http://php.net/open-basedir
+-open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/
++open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/:/build/:/usr/bin/:/proc/
+
+ ; This directive allows you to disable certain functions for security reasons.
+ ; It receives a comma-delimited list of function names.
+@@ -606,7 +606,7 @@
+ ; Development Value: "GPCS"
+ ; Production Value: "GPCS";
+ ; http://php.net/variables-order
+-variables_order = "GPCS"
++variables_order = "EGPCS"
+
+ ; This directive determines which super global data (G,P & C) should be
+ ; registered into the super global array REQUEST. If so, it also determines
+@@ -897,14 +897,14 @@
+ ;extension=pdo_sqlite.so
+ ;extension=pgsql.so
+ ;extension=phar.so
+-;extension=posix.so
++extension=posix.so
+ ;extension=pspell.so
+ ;extension=shmop.so
+ ;extension=snmp.so
+ ;extension=soap.so
+ ;extension=sockets.so
+ ;extension=sqlite3.so
+-;extension=sysvmsg.so
++extension=sysvmsg.so
+ ;extension=sysvsem.so
+ ;extension=sysvshm.so
+ ;extension=tidy.so