summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Alexander2017-01-13 12:22:22 +1100
committerMichael Alexander2017-01-13 12:22:22 +1100
commit02e1864de1aed6f00e34b2eb9873940ef0ffed3d (patch)
tree47a79900907bd4a1c7b8f021c050d388fd7fbf26
parent095005dad9c5616183702fd7db96cbc5bcd0bd7d (diff)
downloadaur-02e1864de1aed6f00e34b2eb9873940ef0ffed3d.tar.gz
Updated to 3.17.1
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f26015f51c77..94f7bc00a78e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
# Maintainer: Michael Alexander <beefsack@gmail.com>
pkgname=hhvm-hack-git
-pkgver=3.15.2
+pkgver=3.17.1
pkgrel=1
pkgdesc="HHVM's Hack tools (hh_client, hh_server, hh_format et al.)"
arch=('x86_64')
url="http://hacklang.org/"
license=('PHP')
-makedepends=('git' 'ocaml' 'ocamlbuild' 'ocaml-compiler-libs' 'ocaml-ctypes' 'gcc' 'cmake')
+makedepends=('git' 'ocaml' 'ocamlbuild' 'ocaml-compiler-libs' 'ocaml-ctypes' 'gcc' 'cmake' 'libdwarf')
conflicts=("hhvm")
source=(
- "https://github.com/facebook/hhvm/commit/7f556de.patch"
+ #'https://github.com/facebook/hhvm/commit/2a4d3da.patch'
"hhvm::git+https://github.com/facebook/hhvm#tag=HHVM-${pkgver}"
)
md5sums=(
- '5cc6f0e19f1d8948136e06fe84ed5f2d'
+ #'a9b12ff007d9590a25d7a945edf590c7'
'SKIP'
)
prepare() {
cd "$srcdir/hhvm"
- git apply "$srcdir/7f556de.patch"
+ #git apply "$srcdir/2a4d3da.patch"
}
build() {
cd "$srcdir/hhvm"
git submodule update --init --recursive
cd hphp/hack
- cmake .
+ cmake -D CMAKE_MODULE_PATH=../../CMake .
make
}