summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Alexander2017-01-13 12:23:29 +1100
committerMichael Alexander2017-01-13 12:23:29 +1100
commitaa3d896db700261195d0b3a46c0a727beda17e4d (patch)
tree7e807c32414e797a41b9bdd536c33ccff8cc920f
parent095005dad9c5616183702fd7db96cbc5bcd0bd7d (diff)
downloadaur-aa3d896db700261195d0b3a46c0a727beda17e4d.tar.gz
Updated to 3.17.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63b4f7c02ab6..4cd1dbcb1d6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hhvm-hack-git
pkgdesc = HHVM's Hack tools (hh_client, hh_server, hh_format et al.)
- pkgver = 3.15.2
+ pkgver = 3.17.1
pkgrel = 1
url = http://hacklang.org/
arch = x86_64
@@ -12,10 +12,9 @@ pkgbase = hhvm-hack-git
makedepends = ocaml-ctypes
makedepends = gcc
makedepends = cmake
+ makedepends = libdwarf
conflicts = hhvm
- source = https://github.com/facebook/hhvm/commit/7f556de.patch
- source = hhvm::git+https://github.com/facebook/hhvm#tag=HHVM-3.15.2
- md5sums = 5cc6f0e19f1d8948136e06fe84ed5f2d
+ source = hhvm::git+https://github.com/facebook/hhvm#tag=HHVM-3.17.1
md5sums = SKIP
pkgname = hhvm-hack-git
diff --git a/PKGBUILD b/PKGBUILD
index f26015f51c77..94f7bc00a78e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
# Maintainer: Michael Alexander <beefsack@gmail.com>
pkgname=hhvm-hack-git
-pkgver=3.15.2
+pkgver=3.17.1
pkgrel=1
pkgdesc="HHVM's Hack tools (hh_client, hh_server, hh_format et al.)"
arch=('x86_64')
url="http://hacklang.org/"
license=('PHP')
-makedepends=('git' 'ocaml' 'ocamlbuild' 'ocaml-compiler-libs' 'ocaml-ctypes' 'gcc' 'cmake')
+makedepends=('git' 'ocaml' 'ocamlbuild' 'ocaml-compiler-libs' 'ocaml-ctypes' 'gcc' 'cmake' 'libdwarf')
conflicts=("hhvm")
source=(
- "https://github.com/facebook/hhvm/commit/7f556de.patch"
+ #'https://github.com/facebook/hhvm/commit/2a4d3da.patch'
"hhvm::git+https://github.com/facebook/hhvm#tag=HHVM-${pkgver}"
)
md5sums=(
- '5cc6f0e19f1d8948136e06fe84ed5f2d'
+ #'a9b12ff007d9590a25d7a945edf590c7'
'SKIP'
)
prepare() {
cd "$srcdir/hhvm"
- git apply "$srcdir/7f556de.patch"
+ #git apply "$srcdir/2a4d3da.patch"
}
build() {
cd "$srcdir/hhvm"
git submodule update --init --recursive
cd hphp/hack
- cmake .
+ cmake -D CMAKE_MODULE_PATH=../../CMake .
make
}