summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2015-07-08 15:23:45 +0200
committerFlorian Bruhin2015-07-08 15:23:45 +0200
commit60879ebeb2ef5d9cb942024ed767b1cbc08d59ef (patch)
treec37e50060464d1c79fbead824a6aebe3ae2bd278
downloadaur-60879ebeb2ef5d9cb942024ed767b1cbc08d59ef.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0e3176aa461
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hib-dlagent
+ pkgdesc = Tool to download Humble Indie Bundle binaries by file name
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/hagabaka/hib-dlagent
+ arch = any
+ license = GPL2
+ depends = curl
+ depends = python-humblebundle
+ optdepends = gnome-keyring-query: encrypted account password support
+ source = hib-dlagent-0.7.tar.gz::https://github.com/hagabaka/hib-dlagent/archive/0.7.tar.gz
+ source = none-url.patch::https://github.com/hagabaka/hib-dlagent/commit/f4c40f6d02094f9ecb46d956265977284e8f3acb.patch
+ sha256sums = 2b6aa4e98e8e525a821843de4df5db890882eb8d20c09d7b30639e4c747ddc4e
+ sha256sums = 3598dc291cb249cffb522b914de162218776f24f9f470a37dd472d7d74987127
+
+pkgname = hib-dlagent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7936ebe94c14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Eric Anderson <ejona86@gmail.com>
+# Maintainer: Florian Bruhin <archlinux.org@the-compiler.org>
+
+pkgname=hib-dlagent
+pkgver=0.7
+pkgrel=1
+pkgdesc='Tool to download Humble Indie Bundle binaries by file name'
+arch=('any')
+url='https://github.com/hagabaka/hib-dlagent'
+license=('GPL2')
+depends=('curl' 'python-humblebundle')
+optdepends=('gnome-keyring-query: encrypted account password support')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hagabaka/hib-dlagent/archive/${pkgver}.tar.gz"
+ "none-url.patch::https://github.com/hagabaka/hib-dlagent/commit/f4c40f6d02094f9ecb46d956265977284e8f3acb.patch")
+sha256sums=('2b6aa4e98e8e525a821843de4df5db890882eb8d20c09d7b30639e4c747ddc4e'
+ '3598dc291cb249cffb522b914de162218776f24f9f470a37dd472d7d74987127')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -p1 < "$srcdir/none-url.patch"
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ DEST="$pkgdir" ./install.sh
+}