summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-11-10 08:53:33 -0700
committerAinola2018-11-10 08:53:36 -0700
commit70ef0e23a3ed618595461468a19bc7ed96672d5a (patch)
tree7de3cb3717262799e37b7471ec560f8326232300
parentbc256ea5a0e7c557c937bdb4c1e99cd78e503e66 (diff)
downloadaur-70ef0e23a3ed618595461468a19bc7ed96672d5a.tar.gz
upgpkg: 0.7.1, new license, rm patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bd53b892b94..dd3f04551d97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = hib-dlagent
pkgdesc = Tool to download Humble Indie Bundle binaries by file name
- pkgver = 0.7
- pkgrel = 3
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://github.com/hagabaka/hib-dlagent
arch = any
- license = GPL2
+ license = MIT
depends = bash
depends = curl
depends = python-humblebundle
optdepends = gnome-keyring-query: encrypted account password support
- source = hib-dlagent-0.7.tar.gz::https://github.com/hagabaka/hib-dlagent/archive/0.7.tar.gz
- source = hib-dlagent-no_url_error.patch::https://github.com/hagabaka/hib-dlagent/commit/f4c40f6d02094f9ecb46d956265977284e8f3acb.patch
- sha256sums = 2b6aa4e98e8e525a821843de4df5db890882eb8d20c09d7b30639e4c747ddc4e
- sha256sums = 3598dc291cb249cffb522b914de162218776f24f9f470a37dd472d7d74987127
+ source = hib-dlagent-0.7.1.tar.gz::https://github.com/hagabaka/hib-dlagent/archive/0.7.1.tar.gz
+ sha256sums = fb3190ce8442e9b3bacede0f5ae1f63f6b083639d30cb006aaff69d73c5ca7df
pkgname = hib-dlagent
diff --git a/PKGBUILD b/PKGBUILD
index cf7a2c6f0310..39e63a064321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,21 @@
# Contributor: Eric Anderson
pkgname=hib-dlagent
-pkgver=0.7
-pkgrel=3
+pkgver=0.7.1
+pkgrel=1
pkgdesc='Tool to download Humble Indie Bundle binaries by file name'
arch=('any')
url='https://github.com/hagabaka/hib-dlagent'
-license=('GPL2')
+license=('MIT')
depends=('bash' 'curl' 'python-humblebundle')
optdepends=('gnome-keyring-query: encrypted account password support')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/hagabaka/hib-dlagent/archive/$pkgver.tar.gz"
- "$pkgname-no_url_error.patch::https://github.com/hagabaka/hib-dlagent/commit/f4c40f6d02094f9ecb46d956265977284e8f3acb.patch")
-sha256sums=('2b6aa4e98e8e525a821843de4df5db890882eb8d20c09d7b30639e4c747ddc4e'
- '3598dc291cb249cffb522b914de162218776f24f9f470a37dd472d7d74987127')
-
-prepare() {
- patch -d "$pkgname-$pkgver" -p1 < "$pkgname-no_url_error.patch"
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/hagabaka/hib-dlagent/archive/$pkgver.tar.gz")
+sha256sums=('fb3190ce8442e9b3bacede0f5ae1f63f6b083639d30cb006aaff69d73c5ca7df')
package() {
cd "$pkgname-$pkgver"
install -Dm644 README -t "$pkgdir/usr/share/doc/hib-dlagent/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm755 hib-dlagent -t "$pkgdir/usr/bin/"
install -Dm755 discover-url.py -t "$pkgdir/usr/share/hib-dlagent/"
}