summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAetf2020-04-03 23:39:52 -0400
committerAetf2020-04-03 23:39:52 -0400
commit22bd30ec0bccd348e6bf4e41e3bd40e1817da3df (patch)
tree0521214d76a093483b1b24bbfb545d4b34f8c0be
parent0ab9d31dae125c54a1046c78fbddb9fdf4e89e2b (diff)
downloadaur-hid-apple-patched-git-dkms.tar.gz
Reorganize install locations, and automatically rebuild initramfs
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
-rw-r--r--hid-apple-patched-dkms.install8
-rw-r--r--hid_apple.depmod (renamed from hid-apple-patched.conf)0
-rw-r--r--hid_apple.modprobe11
-rw-r--r--hid_apple_pclayout.conf5
6 files changed, 28 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5844cdb597e..b64de26c71ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hid-apple-patched-git-dkms
- pkgdesc = Allows to swap the Fn key and left Control key on Macbook Pro and Apple keyboards in GNU/Linux (DKMS)
- pkgver = 20200331.f7f6560
+ pkgdesc = Swaping the Fn and left Control keys and some other mapping tweaks on Macbook Pro and Apple keyboards (DKMS)
+ pkgver = 20200401.5ebf708
pkgrel = 1
url = https://github.com/free5lot/hid-apple-patched
install = hid-apple-patched-dkms.install
@@ -8,13 +8,14 @@ pkgbase = hid-apple-patched-git-dkms
license = GPL2
makedepends = git
depends = dkms
+ depends = mkinitcpio-modconf-hook
source = git+https://github.com/free5lot/hid-apple-patched#branch=master
- source = hid-apple-patched.conf
- source = hid_apple_pclayout.conf
+ source = hid_apple.depmod
+ source = hid_apple.modprobe
source = dkms.conf
sha256sums = SKIP
sha256sums = 4b94f1f55febddad5ff60a8918487b883ceadd4e6c3fb280e98e4e235cd09663
- sha256sums = 2a493d3973b80b815779643b2c1039f52c05e2e9a65cebd00b2a1da105630cbb
+ sha256sums = bf214ca80aa4abb6fe85c1108ea7c941684a5bc57891982b0aefafd5a6339a26
sha256sums = 5d2457728a93e73a96f2ca88f66455859363f083097ad20e661bdc12dc44a9ba
pkgname = hid-apple-patched-git-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 5d4bb5460196..cf62607c147f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,30 @@
# Contributor: juantascon <juantascon.aur@horlux.org>
# Contributor: Ilya Kuzmin <i.g.kuzmin.spb@gmail.com>
-pkgname='hid-apple-patched-git-dkms'
+pkgname=hid-apple-patched-git-dkms
_pkgname=hid-apple-patched
-pkgver=20200331.f7f6560
+pkgver=20200401.5ebf708
pkgrel=1
url="https://github.com/free5lot/hid-apple-patched"
arch=('any')
license=('GPL2')
-pkgdesc="Allows to swap the Fn key and left Control key on Macbook Pro and Apple keyboards in GNU/Linux (DKMS)"
+pkgdesc="Swaping the Fn and left Control keys and some other mapping tweaks on Macbook Pro and Apple keyboards (DKMS)"
-depends=('dkms')
+depends=('dkms' 'mkinitcpio-modconf-hook')
makedepends=('git')
install=hid-apple-patched-dkms.install
source=("git+https://github.com/free5lot/$_pkgname#branch=master"
- "hid-apple-patched.conf"
- "hid_apple_pclayout.conf"
+ "hid_apple.depmod"
+ "hid_apple.modprobe"
"dkms.conf")
sha256sums=('SKIP'
'4b94f1f55febddad5ff60a8918487b883ceadd4e6c3fb280e98e4e235cd09663'
- '2a493d3973b80b815779643b2c1039f52c05e2e9a65cebd00b2a1da105630cbb'
+ 'bf214ca80aa4abb6fe85c1108ea7c941684a5bc57891982b0aefafd5a6339a26'
'5d2457728a93e73a96f2ca88f66455859363f083097ad20e661bdc12dc44a9ba')
pkgver() {
@@ -44,6 +44,6 @@ package() {
-e "s/@PKGVER@/${pkgver}/" \
-i "${pkgdir}"/usr/src/${_pkgname}-${pkgver}/dkms.conf
- install -Dm644 hid_apple_pclayout.conf "${pkgdir}"/etc/modprobe.d/hid_apple_pclayout.conf
- install -Dm644 hid-apple-patched.conf "$pkgdir"/etc/depmod.d/hid-apple-patched.conf
+ install -Dm644 hid_apple.modprobe "${pkgdir}"/usr/lib/modprobe.d/hid_apple.conf
+ install -Dm644 hid_apple.depmod "${pkgdir}"/usr/lib/depmod.d/hid_apple.conf
}
diff --git a/hid-apple-patched-dkms.install b/hid-apple-patched-dkms.install
index 7e100e78c333..9e0224c371e8 100644
--- a/hid-apple-patched-dkms.install
+++ b/hid-apple-patched-dkms.install
@@ -13,13 +13,9 @@ do_install() {
==> hid-apple-patched install/upgrade note:
------------------------------------------------------------------------------
-Configuration file is installed to /etc/modprobe.d/hid_apple_pclayout.conf.
-By default PC-like layout is enabled. You can tweak it to suit your needs
-according to https://github.com/free5lot/hid-apple-patched#configuration.
+Default configuration file is installed to /usr/lib/modprobe.d/hid_apple.conf.
-To make changes work automatically after boot, please rebuild the initramfs.
-See https://wiki.archlinux.org/index.php/Apple_Keyboard#Use_a_patch_to_hid-apple
-for details.
+Wiki: https://wiki.archlinux.org/index.php/Apple_Keyboard#Use_a_patch_to_hid-apple
EOF
}
diff --git a/hid-apple-patched.conf b/hid_apple.depmod
index 85cab0d67386..85cab0d67386 100644
--- a/hid-apple-patched.conf
+++ b/hid_apple.depmod
diff --git a/hid_apple.modprobe b/hid_apple.modprobe
new file mode 100644
index 000000000000..a7de4c84786a
--- /dev/null
+++ b/hid_apple.modprobe
@@ -0,0 +1,11 @@
+# Enable PC-like layout by default.
+# To override, copy this file to /etc/modprobe.d/hid_apple.conf and make
+# desired changes. Note that /etc/modprobe.d/hid_apple.conf will completely
+# replace this file, and the content is NOT merged.
+#
+# Option reference: https://github.com/free5lot/hid-apple-patched#configuration
+options hid_apple fnmode=2
+options hid_apple swap_fn_leftctrl=1
+options hid_apple swap_opt_cmd=1
+options hid_apple rightalt_as_rightctrl=1
+options hid_apple ejectcd_as_delete=1
diff --git a/hid_apple_pclayout.conf b/hid_apple_pclayout.conf
deleted file mode 100644
index e4c1d8ab4d9c..000000000000
--- a/hid_apple_pclayout.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-options hid_apple fnmode=2
-options hid_apple swap_fn_leftctrl=1
-options hid_apple swap_opt_cmd=1
-options hid_apple rightalt_as_rightctrl=1
-options hid_apple ejectcd_as_delete=1