summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNadia Holmquist Pedersen2020-12-26 23:56:22 +0100
committerNadia Holmquist Pedersen2020-12-26 23:56:22 +0100
commit17e63a0cd2ce60dfcdec07371cab29c69744c000 (patch)
tree2b0be597adf27d0d0fed15436f77dd88731db282
parentb03de5bde90cca104b2500d0b598ce4c26cb5c8b (diff)
downloadaur-17e63a0cd2ce60dfcdec07371cab29c69744c000.tar.gz
Patch out force feedback enabled check to make rumble work
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--disable-ff-enabled-check.patch19
3 files changed, 28 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d0cb008ad0b..689c41b06f77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,11 +11,13 @@ pkgbase = hid-playstation-dkms
source = hid-ids.h
source = Makefile
source = work-without-modifying-hid-quirks.patch
+ source = disable-ff-enabled-check.patch
md5sums = ea60e546559ded5ac2ef03f8f6950145
md5sums = 6d97239c33773b3f2fc5d497e98a1017
md5sums = c9585c976df5c262127bfe8b595824b3
md5sums = b5424fcb24f12a53b4ff18f1b85bcb23
md5sums = 52c3680b1fad94cc4cc5b1081bb1c9b5
+ md5sums = 4a14732dbadd6419ce0ae49ecad8eaed
pkgname = hid-playstation-dkms
diff --git a/PKGBUILD b/PKGBUILD
index a81d603a2212..526c5de5be77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=hid-playstation
pkgname=${_pkgbase}-dkms
pkgver=20201219
-pkgrel=1
+pkgrel=2
pkgdesc="Sony's official HID driver for the PS5 DualSense controller."
arch=(any)
url="https://patchwork.kernel.org/project/linux-input/list/?series=404369"
@@ -12,13 +12,15 @@ depends=('dkms')
source=(
'hid-playstation.c' 'dkms.conf' 'hid-ids.h' 'Makefile'
'work-without-modifying-hid-quirks.patch'
+ 'disable-ff-enabled-check.patch'
)
md5sums=('ea60e546559ded5ac2ef03f8f6950145'
'6d97239c33773b3f2fc5d497e98a1017'
'c9585c976df5c262127bfe8b595824b3'
'b5424fcb24f12a53b4ff18f1b85bcb23'
- '52c3680b1fad94cc4cc5b1081bb1c9b5')
+ '52c3680b1fad94cc4cc5b1081bb1c9b5'
+ '4a14732dbadd6419ce0ae49ecad8eaed')
package() {
cd "${srcdir}"
@@ -35,4 +37,7 @@ package() {
# driver's source file to do it there instead, like hid-nintendo does.
cd "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
patch -Np1 -i "${srcdir}/work-without-modifying-hid-quirks.patch"
+
+ # Enable force feedback support
+ patch -Np1 -i "${srcdir}/disable-ff-enabled-check.patch"
}
diff --git a/disable-ff-enabled-check.patch b/disable-ff-enabled-check.patch
new file mode 100644
index 000000000000..2f3677e4991f
--- /dev/null
+++ b/disable-ff-enabled-check.patch
@@ -0,0 +1,19 @@
+diff --git a/hid-playstation.c b/hid-playstation.c
+index 2f989da..0bb77d9 100644
+--- a/hid-playstation.c
++++ b/hid-playstation.c
+@@ -442,12 +442,12 @@ static struct input_dev *ps_gamepad_create(struct hid_device *hdev,
+ for (i = 0; i < ARRAY_SIZE(ps_gamepad_buttons); i++)
+ input_set_capability(gamepad, EV_KEY, ps_gamepad_buttons[i]);
+
+-#if IS_ENABLED(CONFIG_PLAYSTATION_FF)
++//#if IS_ENABLED(CONFIG_PLAYSTATION_FF)
+ if (play_effect) {
+ input_set_capability(gamepad, EV_FF, FF_RUMBLE);
+ input_ff_create_memless(gamepad, NULL, play_effect);
+ }
+-#endif
++//#endif
+
+ ret = input_register_device(gamepad);
+ if (ret)