summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNadia Holmquist Pedersen2021-01-04 20:14:09 +0100
committerNadia Holmquist Pedersen2021-01-04 20:14:09 +0100
commit7daf701b201e08ff030e0feae18821a246f5b8af (patch)
tree7db49fec16eaf80880c049caa32650b8a3eb8ac3
parentf8d2880f06b59fec19bdd9aadf3962355efa39e4 (diff)
downloadaur-7daf701b201e08ff030e0feae18821a246f5b8af.tar.gz
Actually use the FF disable check patch instead of modifying the source file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--hid-playstation.c4
3 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 268020e3b1b0..34ff8ca1f54a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hid-playstation-dkms
pkgdesc = Sony's official HID driver for the PS5 DualSense controller.
pkgver = 20210102
- pkgrel = 1
+ pkgrel = 2
url = https://patchwork.kernel.org/project/linux-input/list/?series=404369
arch = any
license = GPL2
@@ -10,10 +10,12 @@ pkgbase = hid-playstation-dkms
source = dkms.conf
source = hid-ids.h
source = Makefile
- md5sums = 1ede5a2b91a03a1f246bf8eda0d4258e
+ source = disable-ff-enabled-check.patch
+ md5sums = 11ca4528b5be12abe371027ded0f7012
md5sums = 6d97239c33773b3f2fc5d497e98a1017
md5sums = c9585c976df5c262127bfe8b595824b3
md5sums = b5424fcb24f12a53b4ff18f1b85bcb23
+ md5sums = 4a14732dbadd6419ce0ae49ecad8eaed
pkgname = hid-playstation-dkms
diff --git a/PKGBUILD b/PKGBUILD
index c3ecedf97e35..1bc52552c249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
_pkgbase=hid-playstation
pkgname=${_pkgbase}-dkms
pkgver=20210102
-pkgrel=1
+pkgrel=2
pkgdesc="Sony's official HID driver for the PS5 DualSense controller."
arch=(any)
url="https://patchwork.kernel.org/project/linux-input/list/?series=404369"
license=("GPL2")
depends=('dkms')
-source=('hid-playstation.c' 'dkms.conf' 'hid-ids.h' 'Makefile')
+source=(
+ 'hid-playstation.c' 'dkms.conf' 'hid-ids.h' 'Makefile'
+ disable-ff-enabled-check.patch
+)
-md5sums=('1ede5a2b91a03a1f246bf8eda0d4258e'
+md5sums=('11ca4528b5be12abe371027ded0f7012'
'6d97239c33773b3f2fc5d497e98a1017'
'c9585c976df5c262127bfe8b595824b3'
- 'b5424fcb24f12a53b4ff18f1b85bcb23')
+ 'b5424fcb24f12a53b4ff18f1b85bcb23'
+ '4a14732dbadd6419ce0ae49ecad8eaed')
package() {
cd "${srcdir}"
@@ -25,4 +29,7 @@ package() {
-i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
install -Dm644 hid-playstation.c hid-ids.h Makefile \
-t "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+
+ cd "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+ patch -Np1 -i "${srcdir}/disable-ff-enabled-check.patch"
}
diff --git a/hid-playstation.c b/hid-playstation.c
index f44ae3aa73f7..8440af6d6cd7 100644
--- a/hid-playstation.c
+++ b/hid-playstation.c
@@ -455,12 +455,12 @@ static struct input_dev *ps_gamepad_create(struct hid_device *hdev,
for (i = 0; i < ARRAY_SIZE(ps_gamepad_buttons); i++)
input_set_capability(gamepad, EV_KEY, ps_gamepad_buttons[i]);
-//#if IS_ENABLED(CONFIG_PLAYSTATION_FF)
+#if IS_ENABLED(CONFIG_PLAYSTATION_FF)
if (play_effect) {
input_set_capability(gamepad, EV_FF, FF_RUMBLE);
input_ff_create_memless(gamepad, NULL, play_effect);
}
-//#endif
+#endif
ret = input_register_device(gamepad);
if (ret)